Select networking manager with VIRTUAL-RUNTIME_net_manager at distro level
[AGL/meta-agl.git] / meta-agl / recipes-connectivity / connman-ncurses / connman-ncurses_git.bb
1 SUMMARY = "A simple ncurses interface for connman"
2 DESCRIPTION = "A simple ncurses interface for connman"
3 HOMEPAGE = "https://gitlab.com/iotbzh/connman-json-client"
4
5 SECTION = "console/network"
6
7 DEPENDS = "dbus ncurses connman json-c"
8
9 LICENSE = "GPLv2"
10 LIC_FILES_CHKSUM = "file://LICENSE;md5=8c16666ae6c159876a0ba63099614381"
11
12 SRC_URI = "git://gitlab.com/iotbzh/connman-json-client.git;protocol=https;rev=ad4261a2f87c914667b1f6841c913f6b08d373e2"
13
14 inherit autotools pkgconfig
15
16 EXTRA_AUTORECONF += " -i"
17 EXTRA_OECONF += " --disable-optimization --enable-debug"
18
19 S = "${WORKDIR}/git"
20
21 do_install () {
22     install -dm755 ${D}${bindir}
23     install -Dm755 connman_ncurses ${D}${bindir}
24 }
25
26 FILES_${PN} = "${bindir}/connman_ncurses"