Fix hvacplugin cross-compilation issue due to wrong path in CMakeLists.txt
[AGL/meta-agl.git] / meta-agl / recipes-automotive / hvacplugin / hvacplugin_0.1.bb
1 SUMMARY = "hvacplugin"
2
3 LICENSE = "GPLv2+"
4 LIC_FILES_CHKSUM = "file://COPYING;md5=751419260aa954499f7abaabaa882bbe \
5                     file://hvacplugin.cpp;startline=4;endline=11;md5=5adb69b6702cd5745961047a30ef560a"
6
7 SRC_URI = "git://github.com/iotbzh/hvacplugin \
8            file://hvacplugin \
9            file://0001-Fix-boost-include-statement.patch \
10           "
11 SRCREV = "253e3d98505108f652ba875544fde4f58d4714c8"
12 S = "${WORKDIR}/git"
13
14 DEPENDS = "glib-2.0 json-c automotive-message-broker"
15 RDEPENDS_{PN} = "automotive-message-broker"
16
17 inherit cmake pkgconfig
18
19 EXTRA_OECMAKE += "-DPLUGIN_INSTALL_PATH=${libdir}/automotive-message-broker"
20
21 do_install_append() {
22        install -Dm 0644 ${WORKDIR}/hvacplugin ${D}/${sysconfdir}/ambd/plugins.d/hvacplugin
23 }
24
25 FILES_${PN} += "${libdir}/automotive-message-broker/*.so"
26 FILES_${PN}-dbg += "${libdir}/automotive-message-broker/.debug"
27