Add Yocto Project scarthgap release compatibility
authorScott Murray <scott.murray@konsulko.com>
Sun, 20 Nov 2022 23:09:04 +0000 (18:09 -0500)
committerjenkins-dontreply@build.automotivelinux.org <collab-it+agl-jobbuilder@linuxfoundation.org>
Wed, 24 Apr 2024 16:37:45 +0000 (16:37 +0000)
Switch to scarthgap in LAYERSERIES_COMPAT in layer.conf files.

Bug-AGL: SPEC-4578

Change-Id: I50e341efd6a317a830352d44db1cd756d3589861
Signed-off-by: Denys Dmytriyenko <denys@konsulko.com>
meta-agl-drm-lease/conf/layer.conf
meta-agl-flutter/conf/layer.conf
meta-agl-ic-container/conf/layer.conf
meta-agl-jailhouse/conf/layer.conf
meta-agl-test/conf/layer.conf
meta-agl-wireless-monitor/conf/layer.conf
meta-egvirt/conf/layer.conf
meta-oem-production-readiness/meta-agl-basesystem/conf/layer.conf
meta-offline-voice-agent/conf/layer.conf
meta-uhmi/meta-rvgpu/conf/layer.conf

index 7614ba9..7cb075a 100644 (file)
@@ -24,4 +24,4 @@ BBFILES_DYNAMIC += " \
 LAYERVERSION_agl-drm-lease = "1"
 
 LAYERDEPENDS_agl-drm-lease = "core"
-LAYERSERIES_COMPAT_agl-drm-lease = "kirkstone"
+LAYERSERIES_COMPAT_agl-drm-lease = "scarthgap"
index 725a25b..e21f9bc 100644 (file)
@@ -12,7 +12,7 @@ BBFILE_PRIORITY_agl-flutter-layer = "61"
 LAYERVERSION_agl-flutter-layer = "1"
 LAYERDEPENDS_agl-flutter-layer = "core flutter-layer"
 LAYERRECOMMENDS_agl-flutter-layer = "flutter-apps-layer"
-LAYERSERIES_COMPAT_agl-flutter-layer = "kirkstone"
+LAYERSERIES_COMPAT_agl-flutter-layer = "scarthgap"
 
 BBFILES_DYNAMIC += " \
     flutter-apps-layer:${LAYERDIR}/dynamic-layers/flutter-apps-layer/*/*/*/*.bbappend \
index ca1bf7a..47000a7 100644 (file)
@@ -18,5 +18,5 @@ BBFILES_DYNAMIC += " \
     selinux:${LAYERDIR}/dynamic-layers/meta-selinux/*/*/*.bbappend \
 "
 
-LAYERSERIES_COMPAT_aglcontainermc = "kirkstone"
+LAYERSERIES_COMPAT_aglcontainermc = "scarthgap"
 LAYERDEPENDS_aglcontainermc = "aglcore qt5-layer openembedded-layer virtualization-layer agl-drm-lease meta-pipewire"
index 5dd68b2..f561a86 100644 (file)
@@ -11,7 +11,7 @@ BBFILE_PRIORITY_agl-jailhouse = "61"
 # This should only be incremented on significant changes that will
 # cause compatibility issues with other layers
 LAYERVERSION_agl-jailhouse = "1"
-LAYERSERIES_COMPAT_agl-jailhouse = "kirkstone"
+LAYERSERIES_COMPAT_agl-jailhouse = "scarthgap"
 
 # This is only needed for Raspberry Pi
 # TODO: can this be expressed dynamically?
index f8dba7c..a1c1820 100644 (file)
@@ -11,4 +11,4 @@ BBFILE_PATTERN_agl-test = "^${LAYERDIR}/"
 # cause compatibility issues with other layers
 LAYERVERSION_agl-test = "1"
 
-LAYERSERIES_COMPAT_agl-test = "kirkstone"
+LAYERSERIES_COMPAT_agl-test = "scarthgap"
index 9e4f91b..e21fa98 100644 (file)
@@ -12,4 +12,4 @@ BBFILE_PRIORITY_agl-drm-lease = "100"
 # cause compatibility issues with other layers
 LAYERVERSION_agl-wireless-monitor = "1"
 
-LAYERSERIES_COMPAT_agl-wireless-monitor = "kirkstone"
+LAYERSERIES_COMPAT_agl-wireless-monitor = "scarthgap"
index a8dcafd..1aea899 100644 (file)
@@ -11,6 +11,6 @@ BBFILE_PRIORITY_egvirt = "61"
 # This should only be incremented on significant changes that will
 # cause compatibility issues with other layers
 LAYERVERSION_egvirt = "1"
-LAYERSERIES_COMPAT_egvirt = "kirkstone"
+LAYERSERIES_COMPAT_egvirt = "scarthgap"
 
 LAYERDEPENDS_egvirt = "core clang-layer filesystems-layer"
index 10c86f6..e75e0fc 100644 (file)
@@ -12,5 +12,5 @@ BBFILE_PRIORITY_agl-basesystem = "60"
 # This should only be incremented on significant changes that will
 # cause compatibility issues with other layers
 LAYERVERSION_agl-basesystem = "1"
-LAYERSERIES_COMPAT_agl-basesystem = "kirkstone"
+LAYERSERIES_COMPAT_agl-basesystem = "scarthgap"
 LAYERDEPENDS_agl-basesystem = "core"
index e5dca63..83ed05d 100644 (file)
@@ -10,7 +10,7 @@ BBFILE_PATTERN_meta-offline-voice-agent = "^${LAYERDIR}/"
 BBFILE_PRIORITY_meta-offline-voice-agent = "65"
 
 LAYERDEPENDS_meta-offline-voice-agent = "core"
-LAYERSERIES_COMPAT_meta-offline-voice-agent = "dunfell kirkstone"
+LAYERSERIES_COMPAT_meta-offline-voice-agent = "scarthgap"
 
 BBFILES_DYNAMIC += " \
     agldemo:${LAYERDIR}/dynamic-layers/meta-agl-demo/*/*/*.bb \
index b33aa32..5451560 100644 (file)
@@ -14,4 +14,4 @@ BBFILES_DYNAMIC += " \
     raspberrypi:${LAYERDIR}/dynamic-layers/raspberrypi/*/*/*.bbappend \
 "
 
-LAYERSERIES_COMPAT_meta-rvgpu= "kirkstone"
+LAYERSERIES_COMPAT_meta-rvgpu= "scarthgap"