meta-agl-flutter: mask out libstd-rs bbappend 49/29749/1
authorScott Murray <scott.murray@konsulko.com>
Tue, 19 Mar 2024 19:52:49 +0000 (15:52 -0400)
committerScott Murray <scott.murray@konsulko.com>
Tue, 19 Mar 2024 19:52:49 +0000 (15:52 -0400)
The libstd-rs bbappend in meta-flutter breaks building with newer
versions of Rust, so BBMASK it out for now.  Since the change it
makes is to enable debugging Dart/Rust FFI wrappers, and AGL does
not currently use such functionality, this should not change any
behavior.

Bug-AGL: SPEC-5070

Change-Id: I6984303bfc478a7574992f3d927bdaaeb41afa7c
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
meta-agl-flutter/conf/include/agl-flutter.inc

index f03adfb..cf489d0 100644 (file)
@@ -1,3 +1,7 @@
 AGL_FEATURES += "agl-flutter"
 
 FLUTTER_SDK_TAG = "3.13.9"
+
+# Mask libstd-rs bbappend out since the change it makes does not
+# build with newer versions of Rust.
+BBMASK += "meta-flutter/recipes-devtools/rust/libstd-rs_%.bbappend"