Add agl-service-can-high-level-viwi 94/23594/2 8.99.5 icefish/8.99.5 icefish_8.99.5
authorScott Murray <scott.murray@konsulko.com>
Mon, 20 Jan 2020 19:35:23 +0000 (14:35 -0500)
committerScott Murray <scott.murray@konsulko.com>
Wed, 22 Jan 2020 00:03:09 +0000 (19:03 -0500)
Add agl-service-can-high-level-viwi recipe to replace the
high-level-viwi-service one from meta-agl (which will later be
removed), and update packagegroup-agl-ivi-services to use it.
Also remove high-level-viwi-service and agl-service-signal-composer
from the AGL_APPS list in packagegroup-agl-demo-platform, as they
are already pulled in via packagegroup-agl-ivi-services.

Bug-AGL: SPEC-3113

Change-Id: I4ceab8b5ab1a4653f59749317d1a72c31652ca54
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-apis/agl-service-can-high-level-viwi/agl-service-can-high-level-viwi.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
recipes-platform/packagegroups/packagegroup-agl-ivi-services.bb

diff --git a/recipes-apis/agl-service-can-high-level-viwi/agl-service-can-high-level-viwi.bb b/recipes-apis/agl-service-can-high-level-viwi/agl-service-can-high-level-viwi.bb
new file mode 100644 (file)
index 0000000..7cc58dd
--- /dev/null
@@ -0,0 +1,19 @@
+SUMMARY     = "High level ViWi service"
+DESCRIPTION = "AGL High Level service using ViWi protocol to expose CAN API."
+HOMEPAGE    = "https://git.automotivelinux.org/apps/agl-service-can-high-level-viwi/"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=5de84541278ea4e62cacfdc0f890c459"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/agl-service-can-high-level-viwi;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "4.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# Run-time dependencies
+RDEPENDS_${PN} += "agl-service-can-low-level"
+
+inherit cmake aglwgt
+
+AGLWGT_AUTOINSTALL_${PN} := "0"
index 8fa7e6e..944b34b 100644 (file)
@@ -33,8 +33,6 @@ AGL_APPS = " \
     messaging \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'taskmanager' , '', d)} \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip' , '', d)} \
-    high-level-viwi-service \
-    agl-service-signal-composer \
     low-can-demo \
     virtual/mixer \
     ${@bb.utils.contains('IMAGE_FEATURES', 'agl-voiceagent-alexa', 'alexa-viewer' , '', d)} \
index bc30aed..40359ed 100644 (file)
@@ -13,6 +13,7 @@ RDEPENDS_${PN} += "\
 agl-service-bluetooth \
 agl-service-bluetooth-map \
 agl-service-bluetooth-pbap \
+agl-service-can-high-level-viwi \
 agl-service-can-low-level \
 agl-service-geoclue \
 agl-service-geofence \
@@ -26,5 +27,4 @@ agl-service-signal-composer \
 agl-service-steering-wheel \
 agl-service-unicens \
 agl-service-weather \
-high-level-viwi-service \
     "