chromium*: remove jumbo build options 05/27105/4
authorJose Dapena Paz <jdapena@igalia.com>
Thu, 20 Jan 2022 16:32:19 +0000 (17:32 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 1 Feb 2022 21:50:55 +0000 (21:50 +0000)
Jumbo build is not supported anymore in Chromium. This changeset
removes all references in recipe to that mode.

Bug-AGL: SPEC-4233
Change-Id: I7a667c9a36bd0b825fc3014520d1b23f53828b57
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
recipes-wam/chromium/chromium.inc
recipes-wam/chromium/chromium84_git.bb

index c6bc949..d45dfe7 100644 (file)
@@ -42,15 +42,7 @@ TARGET = "${WEBRUNTIME_BUILD_TARGET} ${BROWSER_APP_BUILD_TARGET}"
 # Skip do_install:append of webos_system_bus. It is not compatible with this component.
 WEBOS_SYSTEM_BUS_FILES_LOCATION = "${S}/files/sysbus"
 
-PACKAGECONFIG ?= "jumbo use-upstream-wayland"
-
-
-# Set a default value for jumbo file merge of 8. This should be good for build
-# servers and workstations with a big number of cores. In case build is
-# happening in a machine with less cores but still enough RAM a good value could
-# be 50.
-JUMBO_FILE_MERGE_LIMIT="8"
-PACKAGECONFIG[jumbo] = "use_jumbo_build=true jumbo_file_merge_limit=${JUMBO_FILE_MERGE_LIMIT}, use_jumbo_build=false"
+PACKAGECONFIG ?= "use-upstream-wayland"
 
 PACKAGECONFIG[lttng] = "use_lttng=true,use_lttng=false,lttng-ust,lttng-tools lttng-modules babeltrace"
 
index 354a75c..24613db 100644 (file)
@@ -18,8 +18,6 @@ BROWSER_APPLICATION = "chromium84-browser"
 BROWSER_APPLICATION_DIR = "/opt/chromium84"
 MKSNAPSHOT_PATH = "v8_snapshot/"
 
-PACKAGECONFIG:remove="jumbo"
-
 GN_ARGS += "use_gtk=false"
 
 # Disable closure_compile