rng-tools: disable jitter entropy generation in VMs 28/28428/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 16 Jan 2023 23:14:47 +0000 (18:14 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 29 Jan 2023 14:29:37 +0000 (14:29 +0000)
Add a bbappend for rng-tools that disables jitter entropy generation
for virtio-all machines, as it provides little value in virtual
machines that are dependent on the host entropy anyways, and slows
their booting very significantly.

Bug-AGL: SPEC-4618

Change-Id: Ia61917253b69f37b003c617d4203c823dd51bb6c
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
(cherry picked from commit ebeba2f0667d7195597d9131a12d880d503a399a)

recipes-support/rng-tools/files/default [new file with mode: 0644]
recipes-support/rng-tools/rng-tools_%.bbappend [new file with mode: 0644]
recipes-support/rng-tools/rng-tools_agldemo.inc [new file with mode: 0644]

diff --git a/recipes-support/rng-tools/files/default b/recipes-support/rng-tools/files/default
new file mode 100644 (file)
index 0000000..6e2f2ca
--- /dev/null
@@ -0,0 +1 @@
+EXTRA_ARGS="-r /dev/hwrng -x jitter"
diff --git a/recipes-support/rng-tools/rng-tools_%.bbappend b/recipes-support/rng-tools/rng-tools_%.bbappend
new file mode 100644 (file)
index 0000000..8ec7f75
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'rng-tools_agldemo.inc', '', d)}
diff --git a/recipes-support/rng-tools/rng-tools_agldemo.inc b/recipes-support/rng-tools/rng-tools_agldemo.inc
new file mode 100644 (file)
index 0000000..283c8a4
--- /dev/null
@@ -0,0 +1,7 @@
+# Pick up modified default configuration for virtual machines
+# that disables jitter entropy source, as it is not useful when
+# the VMs are effectively driven by the host RNG via virtio-rng.
+# This also helps boot speed, as otherwise the guests have rngd
+# potentially somewhat pointlessly burning a lot of CPU on boot,
+# in addition to the host's own rngd.
+FILESEXTRAPATHS:prepend:virtio-all := "${THISDIR}/files:"