html5-settings: create recipe and add to html5 demo 66/23766/2
authorLorenzo Tilve <ltilve@igalia.com>
Mon, 3 Feb 2020 10:46:50 +0000 (11:46 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 11 Feb 2020 21:50:11 +0000 (21:50 +0000)
Bug-AGL: SPEC-2823

Change-Id: Ia58ae3d871b1f5119daf60ea08378aba6fc75046
Signed-off-by: Lorenzo Tilve <ltilve@igalia.com>
recipes-demo-hmi/html5-settings/html5-settings_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo-hmi/html5-settings/html5-settings_git.bb b/recipes-demo-hmi/html5-settings/html5-settings_git.bb
new file mode 100644 (file)
index 0000000..dea1ec3
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 Settings Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-settings/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}
index afedf07..cddab0b 100644 (file)
@@ -20,6 +20,7 @@ RDEPENDS_${PN} += "\
 AGL_APPS = " \
     html5-launcher \
     html5-hvac \
+    html5-settings \
     "
 
 RDEPENDS_${PN}_append = " \