flutter-cluster-dashboard: remove warning 03/28303/1
authorScott Murray <scott.murray@konsulko.com>
Tue, 20 Dec 2022 19:31:29 +0000 (14:31 -0500)
committerScott Murray <scott.murray@konsulko.com>
Tue, 20 Dec 2022 19:34:43 +0000 (14:34 -0500)
Since the navigation support in the Flutter cluster dashboard is
somewhat optional if we're using the navigation streaming, and it
likely needs further development to be usable, remove the warning
about supplying a MapBox API key to avoid unnecessary confusion.

Bug-AGL: SPEC-4640

Change-Id: I0b34cb3b52c06cad09a447fd8b86b8f5eb4f846b
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo/flutter-cluster-dashboard/flutter-cluster-dashboard_git.bb

index 9cf8e7a..d3b28f8 100644 (file)
@@ -34,12 +34,6 @@ APP_CONFIG = "flutter_cluster_dashboard_on_bg-release.json"
 APP_CONFIG:class-runtimedebug = "flutter_cluster_dashboard_on_bg-debug.json"
 APP_CONFIG:class-runtimeprofile = "flutter_cluster_dashboard_on_bg-profile.json"
 
-do_configure:prepend() {
-    if [ "${OPENROUTE_API_KEY}" = "YOU_NEED_TO_SET_IT_IN_LOCAL_CONF" ]; then
-               bbwarn "WARNING: You should set openrouteservice API key to OPENROUTE_API_KEY variable in local.conf."
-       fi
-}
-
 do_install:append() {
     install -D -m 0644 ${WORKDIR}/flutter-cluster-dashboard.service ${D}${systemd_user_unitdir}/flutter-cluster-dashboard.service
     install -d ${D}${systemd_user_unitdir}/agl-session.target.wants