Fix configuration of building Qt5 61/6561/1
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Thu, 15 Sep 2016 11:01:43 +0000 (20:01 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Thu, 15 Sep 2016 11:05:19 +0000 (20:05 +0900)
This patch set configuration of Qt5 as follows:
 - To set 'wayland-egl' as default of platform plugins
 - To remove eglfs because AGL don't use it

Change-Id: Ia1084173a65870c254ed1a7e3584ad0a8a1524f9
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
recipes-qt/qt5/qtbase_%.bbappend

index 026e76f..d302780 100644 (file)
@@ -3,11 +3,12 @@ FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 DEPENDS_append_koelsch = " libegl"
 DEPENDS_append_porter = " libegl"
 
+PACKAGECONFIG_WAYLAND = "${@bb.utils.contains('DISTRO_FEATURES', 'wayland', 'wayland', '', d)}"
 PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
-PACKAGECONFIG_append = " icu accessibility eglfs"
+PACKAGECONFIG_append = " ${PACKAGECONFIG_WAYLAND} icu accessibility"
 PACKAGECONFIG_append_rpi = " fontconfig"
 
 EXTRA_OECONF_append = ""
 
-
-PACKAGECONFIG[gles2]="-opengl es2 -eglfs,,virtual/libgles2 virtual/egl"
+# '-qpa wayland-egl' set wayland-egl as default of platform plagins
+PACKAGECONFIG[wayland]="-qpa wayland-egl -no-qpa-platform-guard"