recipes-demo-hmi: fix file permissions 45/6245/2
authorChristian Gromm <christian.gromm@microchip.com>
Tue, 2 Aug 2016 12:51:34 +0000 (14:51 +0200)
committerGerrit Code Review <gerrit@172.30.200.200>
Wed, 3 Aug 2016 20:39:01 +0000 (20:39 +0000)
This patch makes the pre-compiled demo applications executable by assiging the
suitable permissions when installing them on the rootfs.

Change-Id: I0145d1e983d60e6312c40cc0d3e2c4aa3257b44e
Signed-off-by: Christian Gromm <christian.gromm@microchip.com>
recipes-demo-hmi/ALS2016-demo/can-lin_0.1.bb
recipes-demo-hmi/ALS2016-demo/vod_0.1.bb

index 1cca96c..d94d398 100644 (file)
@@ -18,6 +18,6 @@ do_compile() {
 
 do_install() {
         install -m 0755 -d ${D}${bindir}
-        install -m 0644 ${S}/OptoLyzerMoccaApp ${D}${bindir}
+        install -m 0755 ${S}/OptoLyzerMoccaApp ${D}${bindir}
 }
 
index 670e680..8e3cbf3 100644 (file)
@@ -18,9 +18,9 @@ do_compile() {
 
 do_install() {
         install -m 0755 -d ${D}${bindir} ${D}${base_dir}/home/root ${D}${docdir}/video-on-demand
-        install -m 0644 ${S}/NetworkManager ${D}${bindir}
-        install -m 0644 ${S}/VideoOnDemand ${D}${bindir}
-        install -m 0644 ${S}/vod-client ${D}${bindir}
+        install -m 0755 ${S}/NetworkManager ${D}${bindir}
+        install -m 0755 ${S}/VideoOnDemand ${D}${bindir}
+        install -m 0755 ${S}/vod-client ${D}${bindir}
        install -m 0644 ${S}/config-agl.xml ${D}${base_dir}/home/root
        install -m 0644 ${S}/i2c-slim-amplifier.script ${D}${base_dir}/home/root
        install -m 0644 ${S}/i2c-uda1388-v2.script ${D}${base_dir}/home/root