flutter-ics-homescreen: update recipe and make default 37/29437/2
authorScott Murray <scott.murray@konsulko.com>
Thu, 16 Nov 2023 15:07:43 +0000 (00:07 +0900)
committerScott Murray <scott.murray@konsulko.com>
Thu, 16 Nov 2023 21:02:00 +0000 (21:02 +0000)
Update SRCREV in flutter-ics-homescreen to pick up:

94b78fd Update Kuksa databroker configuration scheme
ca2ba80 Re enable background animation.
4db7a1d Rename config directory to avoid collisions
17b4bf6 Fix hybrid animation.

As well, the patch to change the databroker port has been removed,
and the configuration yaml file updated to give the same effect.
Lastly, the agl-ivi-demo-platform-flutter image recipe has been
updated to use flutter-ics-homescreen.

Bug-AGL: SPEC-4969

Change-Id: I8a2999d09e38a22df01a27ce6ed52cf4dc0b551f
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29437
Reviewed-by: Justin Noel <justin@ics.com>
ci-image-build: Jenkins Job builder account
Reviewed-by: Lisandro Perez Meyer <lpmeyer@ics.com>
Tested-by: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
ci-image-boot-test: Jenkins Job builder account

recipes-demo/flutter-ics-homescreen/files/change_grpc_port.patch [deleted file]
recipes-demo/flutter-ics-homescreen/files/ics-homescreen.yaml
recipes-demo/flutter-ics-homescreen/flutter-ics-homescreen_git.bb
recipes-platform/images/agl-ivi-demo-platform-flutter.bb

diff --git a/recipes-demo/flutter-ics-homescreen/files/change_grpc_port.patch b/recipes-demo/flutter-ics-homescreen/files/change_grpc_port.patch
deleted file mode 100644 (file)
index 2c0488b..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-From 7a7dfd8756c8c742aa3cd829a3644e6ec977aa8b Mon Sep 17 00:00:00 2001
-From: =?UTF-8?q?Lisandro=20P=C3=A9rez=20Meyer?= <lperezmeyer@ics.com>
-Date: Tue, 14 Nov 2023 14:59:45 +0000
-Subject: [PATCH] Set the default port to 55555.
-
-The Docker images seems to be using 55556.
----
- config/config.yaml | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/config/config.yaml b/config/config.yaml
-index 138fe4b..a552299 100644
---- a/config/config.yaml
-+++ b/config/config.yaml
-@@ -1,2 +1,2 @@
- hostname: localhost
--port: 55556
-+port: 55555
---
-2.25.1
-
index f73418a..eb29ea7 100644 (file)
@@ -1,2 +1,3 @@
-authorization : "/etc/xdg/AGL/homescreen/ics-homescreen.token"
+port : 55555
+authorization : "/etc/xdg/AGL/ics-homescreen/ics-homescreen.token"
 use-tls : true
index aa3e923..7774c80 100644 (file)
@@ -7,13 +7,12 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
 
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-ics-homescreen;protocol=https;branch=${AGL_BRANCH} \
-  file://change_grpc_port.patch \
   file://flutter-ics-homescreen.json \
   file://flutter-ics-homescreen.service \
   file://ics-homescreen.yaml \
   file://ics-homescreen.token \
 "
-SRCREV = "70ec8a79a121471a004e7e4c23157d10157e136f"
+SRCREV = "94b78fd369c318baf1a98d4f510d791ea9f17017"
 
 S = "${WORKDIR}/git"
 
@@ -37,9 +36,9 @@ do_install:append() {
   # be readable by other users, but currently that's not doable
   # until a packaging/sandboxing/MAC scheme is (re)implemented or
   # something like OAuth is plumbed in as an alternative.
-  install -d ${D}${sysconfdir}/xdg/AGL/homescreen
+  install -d ${D}${sysconfdir}/xdg/AGL/ics-homescreen
   install -m 0644 ${WORKDIR}/ics-homescreen.yaml ${D}${sysconfdir}/xdg/AGL/
-  install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/homescreen/
+  install -m 0644 ${WORKDIR}/ics-homescreen.token ${D}${sysconfdir}/xdg/AGL/ics-homescreen/
 }
 
 FILES:${PN} += "${datadir} ${sysconfdir}/xdg/AGL"
index dfebce0..82e3288 100644 (file)
@@ -3,19 +3,5 @@ require agl-ivi-demo-base-flutter.bb
 DESCRIPTION = "AGL Flutter Demo Platform image"
 
 AGL_APPS_INSTALL += " \
-    flutter-homescreen \
-    flutter-dashboard \
-    flutter-hvac \
-    ondemandnavi \
-    settings \
-    mediaplayer \
-    messaging \
-    phone \
-    radio \
+    flutter-ics-homescreen \
 "
-
-IMAGE_INSTALL += " \
-    qtquickcontrols2-agl \
-    qtquickcontrols2-agl-style \
-"
-