packagegroup-agl-demo-platform: fix POI API key preloading 17/26117/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 2 Mar 2021 20:34:27 +0000 (15:34 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 9 Mar 2021 10:17:42 +0000 (10:17 +0000)
Fix missing switch from DISTRO_FEATURES to AGL_FEATURES in the
definition of DEMO_PRELOAD.  Also remove the now unused variables
for the old navigation app as cleanup.

Bug-AGL: SPEC-3833

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I39b4d49c0a213f162657f0086b21b81eb0524ab8

recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

index c506d0a..72e5d7a 100644 (file)
@@ -63,13 +63,8 @@ DEMO_UNIT_CONF ?= ""
 #    I2C devices for RTC and HVAC LED support.
 DEMO_UNIT_CONF += " demo-i2c-udev-conf "
 
-# Preload poi API key for demo if requested, and potentially maps for older
-# navigation application if it is configured.
-DEMO_MAPS_LOCALE ?= "uk"
-DEMO_PRELOAD_MAPS = "${@bb.utils.contains("PREFERRED_RPROVIDER_virtual/navigation", "navigation", " navigation-maps-${DEMO_MAPS_LOCALE}", "",d)}"
-
 # Preload only if agl-demo-preload is set
-DEMO_PRELOAD = "${@bb.utils.contains("DISTRO_FEATURES", "agl-demo-preload", " ${DEMO_PRELOAD_MAPS} ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
+DEMO_PRELOAD = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-preload", " ${DEMO_UNIT_CONF} poiapp-api-key", "",d)}"
 
 RDEPENDS_${PN}_append = " \
     weston-ini-conf \