add recipes for identity, data persistence and nfc 83/12783/5
authorLoïc Collignon <loic.collignon@iot.bzh>
Tue, 19 Dec 2017 22:25:30 +0000 (23:25 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Wed, 27 Dec 2017 13:02:32 +0000 (13:02 +0000)
Bug-AGL: SPEC-1187

Change-Id: Id251a7dcf7a37117a3e3a7314d57c062e02af6de
Signed-off-by: Loïc Collignon <loic.collignon@iot.bzh>
recipes-core/packagegroups/packagegroup-agl-image-ivi.bbappend [new file with mode: 0644]
recipes-core/packagegroups/packagegroup-agl-ivi-connectivity.bbappend [new file with mode: 0644]
recipes-core/packagegroups/packagegroup-agl-ivi-identity.bb [new file with mode: 0644]
recipes-demo-hmi/agl-service-data-persistence/agl-service-data-persistence_git.bb [new file with mode: 0644]
recipes-demo-hmi/agl-service-identity-agent/agl-service-identity-agent_git.bb [new file with mode: 0644]
recipes-demo-hmi/agl-service-nfc/agl-service-nfc_git.bb [new file with mode: 0644]

diff --git a/recipes-core/packagegroups/packagegroup-agl-image-ivi.bbappend b/recipes-core/packagegroups/packagegroup-agl-image-ivi.bbappend
new file mode 100644 (file)
index 0000000..e1b68ab
--- /dev/null
@@ -0,0 +1,3 @@
+RDEPENDS_${PN} += " \
+       packagegroup-agl-ivi-identity \
+"
diff --git a/recipes-core/packagegroups/packagegroup-agl-ivi-connectivity.bbappend b/recipes-core/packagegroups/packagegroup-agl-ivi-connectivity.bbappend
new file mode 100644 (file)
index 0000000..84e388c
--- /dev/null
@@ -0,0 +1,6 @@
+
+RDEPENDS_${PN} += "\
+    libnfc \
+    agl-service-nfc \
+"
+
diff --git a/recipes-core/packagegroups/packagegroup-agl-ivi-identity.bb b/recipes-core/packagegroups/packagegroup-agl-ivi-identity.bb
new file mode 100644 (file)
index 0000000..fa157c8
--- /dev/null
@@ -0,0 +1,9 @@
+inherit packagegroup
+
+RDEPENDS_${PN} += "\
+    agl-service-data-persistence \
+    agl-service-identity-agent \
+"
+
+LICENSE = "MIT"
+
diff --git a/recipes-demo-hmi/agl-service-data-persistence/agl-service-data-persistence_git.bb b/recipes-demo-hmi/agl-service-data-persistence/agl-service-data-persistence_git.bb
new file mode 100644 (file)
index 0000000..69ebe7a
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "AGL low level user database binding"
+HOMEPAGE = "https://github.com/iotbzh/agl-identity"
+SECTION = "base"
+
+LICENSE = "MIT"
+LIC_FILES_CHKSUM = "file://../LICENSE;md5=8089a3c40cff9caffd1b9ba5aa3dfd67"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-data-persistence;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+inherit cmake aglwgt pkgconfig
+
+PV = "1.0+git${SRCPV}"
+S = "${WORKDIR}/git/ll-database-binding"
+
+DEPENDS += " af-binder json-c gdbm "
+
diff --git a/recipes-demo-hmi/agl-service-identity-agent/agl-service-identity-agent_git.bb b/recipes-demo-hmi/agl-service-identity-agent/agl-service-identity-agent_git.bb
new file mode 100644 (file)
index 0000000..5a41231
--- /dev/null
@@ -0,0 +1,17 @@
+DESCRIPTION = "AGL identity agent binding"
+HOMEPAGE = "https://gitlab.com/iotbzh/aia-binding"
+SECTION = "base"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://../LICENSE.txt;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-identity-agent;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+PV = "1.0+git${SRCPV}"
+
+inherit cmake aglwgt pkgconfig
+
+S = "${WORKDIR}/git/agl-identity-service"
+
+DEPENDS = "curl af-binder json-c systemd"
+
diff --git a/recipes-demo-hmi/agl-service-nfc/agl-service-nfc_git.bb b/recipes-demo-hmi/agl-service-nfc/agl-service-nfc_git.bb
new file mode 100644 (file)
index 0000000..2862da0
--- /dev/null
@@ -0,0 +1,17 @@
+SUMMARY     = "agl-service-nfc"
+DESCRIPTION = ""
+HOMEPAGE    = "https://www.github.com/iotbzh/nfc-binding"
+SECTION     = "apps"
+DEPENDS     = "af-binder json-c libnfc"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
+
+inherit cmake pkgconfig aglwgt
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-nfc;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+