Add html-examples 73/27673/2
authorJose Dapena Paz <jdapena@igalia.com>
Fri, 17 Jun 2022 14:00:51 +0000 (16:00 +0200)
committerJose Dapena Paz <jdapena@igalia.com>
Tue, 26 Jul 2022 14:19:43 +0000 (16:19 +0200)
Bug-AGL: SPEC-4248
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
Change-Id: Iee0e068aa5fd6f3bf5cb4cab8c5003e109408a8f

recipes-demo/webapp-samples/files/webapps-examples.desktop [new file with mode: 0644]
recipes-demo/webapp-samples/html5-examples_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo/webapp-samples/files/webapps-examples.desktop b/recipes-demo/webapp-samples/files/webapps-examples.desktop
new file mode 100644 (file)
index 0000000..0764cfd
--- /dev/null
@@ -0,0 +1,11 @@
+[Desktop Entry]
+Version=1.0
+Name=HTML5 Examples
+Comment=Examples of web contents
+GenericName=Examples
+Exec=/usr/bin/WebAppMgr --appid=webapps-examples --app-install-dir=/usr/lib/wam_apps/html5-examples/
+Icon=settings
+Terminal=false
+Type=Application
+Categories=System;
+StartupNotify=true
diff --git a/recipes-demo/webapp-samples/html5-examples_git.bb b/recipes-demo/webapp-samples/html5-examples_git.bb
new file mode 100644 (file)
index 0000000..7853797
--- /dev/null
@@ -0,0 +1,11 @@
+SUMMARY     = "AGL HTML5 Examples"
+LICENSE     = "MIT"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=7ea5dd8751060d9f04d2748030c547ed"
+DESKTOP_FILE = "webapps-examples.desktop"
+
+require webapp-samples.inc
+
+do_install:append() {
+  cp -R --no-dereference --preserve=mode,links ${S}/examples/* ${D}${WAM_APPLICATIONS_DIR}/${PN}
+}
+
index 5fe6ec9..cb2c912 100644 (file)
@@ -28,6 +28,7 @@ AGL_APPS = " \
     html5-aquarium \
     html5-youtube \
     html5-jitsi \
+    html5-examples \
     "
 
 RDEPENDS:${PN}:append = " \