wam, chromium, html5-*: improve initial frame, and drop usage of config.xml 14/27414/4
authorJose Dapena Paz <jdapena@igalia.com>
Mon, 18 Apr 2022 14:40:45 +0000 (16:40 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 13 May 2022 12:08:08 +0000 (12:08 +0000)
Move to use appinfo.json, new CLI interface, and fix flickering
partially.

chromium87: be0370b198..c9a66f75a7
c9a66f75a7 fixup! [op][n_upsable][splash][fmp] New splash and FMP implementation
d7953f5e17 Revert "[op][agl][splash] Show immediately apps"

wam: 8dd3f17..f4c2e95
f4c2e95 fixup! agl/web_app_manager_service_agl: Fix minor typo
c072a91 agl/web_app_manager_service_agl: Fix minor typo
761961c web_runtime_agl, web_app_manager_service_agl: Add WebOS appinfo.json support
1ac280e web_runtime_agl: Pass arguments rather than env variables
6e0477f web_runtime_agl: remove setupsurface, nobody is using it
0d83a34 web_runtime_agl: Remove CYNOGARA auth token
4159489 fixup! [op][agl][wayland] Properly adapt dimensions for web apps using panel

html5-homescreen: 21bd1dc..7d89048
7d89048 Launch background after launcher.
5c9e060 Use appinfo.json instead of config.xml
* Change branch to master

html5-launcher: b371797..cb6b66c
cb6b66c  Use appinfo.json instead of config.xml
* Change branch to master

html5-background: 16db46b..7b79640
7b79640 Use appinfo.json instead of config.xml
160a4f9 Add .gitreview file
* Use AGL gerrit and change branch to master

html5-hvac: 45641bf..e64d69b
e64d69b Use appinfo.json instead of config.xml
* Change branch to master

Bug-AGL: SPEC-3982, SPEC-4251, SPEC-4301, SPEC-4312, SPEC-4315
Change-Id: Ibd2bc428910e6e39c52e14b8e969fdea77000a84
Signed-off-by: Jose Dapena Paz <jdapena@igalia.com>
recipes-demo/html5-background/files/webapps-html5-background.desktop
recipes-demo/html5-background/html5-background_git.bb
recipes-demo/html5-homescreen/files/homescreen.service
recipes-demo/html5-homescreen/html5-homescreen_git.bb
recipes-demo/html5-hvac/files/webapps-hvac.desktop
recipes-demo/html5-hvac/html5-hvac_git.bb
recipes-demo/html5-launcher/files/launcher.desktop
recipes-demo/html5-launcher/html5-launcher_git.bb
recipes-wam/chromium/chromium_git.bb
recipes-wam/wam/wam_git.bb

index d53a767..be47470 100644 (file)
@@ -3,7 +3,7 @@ Version=1.0
 Name=HTML5 Background
 Comment=Background
 GenericName=Background
-Exec=env AFM_ID=webapps-html5-background AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-background/ /usr/bin/WebAppMgr
+Exec=/usr/bin/WebAppMgr --appid=webapps-html5-background --app-install-dir=/usr/lib/wam_apps/html5-background/
 Icon=settings
 Terminal=false
 Type=Application
index c06ece0..792b04a 100644 (file)
@@ -9,10 +9,10 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://github.com/AGL-web-applications/background.git;protocol=https;branch=master \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-background;protocol=https;branch=master \
   file://webapps-html5-background.desktop \
 "
-SRCREV = "3b8dae349d428c0230b9885f86d421d43cda5638"
+SRCREV = "7b796408f4ee1ca1b92a02445513d939079af46e"
 
 DEPENDS = "nodejs-native"
 
index 80bc44e..b142c4e 100644 (file)
@@ -5,10 +5,8 @@ After=WebAppMgr.service dbus.service
 
 [Service]
 Type=simple
-Environment=AFM_ID=homescreen
-Environment=AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-homescreen/
 ExecStartPre=sleep 5
-ExecStart=/usr/bin/WebAppMgr
+ExecStart=/usr/bin/WebAppMgr --appid=homescreen --app-install-dir=/usr/lib/wam_apps/html5-homescreen/
 Restart=on-failure
 
 [Install]
index 6958d7b..058e921 100644 (file)
@@ -9,10 +9,10 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH} \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=master \
   file://homescreen.service \
 "
-SRCREV = "21bd1dcdffeafa82948b969062f5221f6e8d480c"
+SRCREV = "5c9e060c508ab5ea49241d3a88f86075d6dc39cf"
 
 DEPENDS = "nodejs-native"
 
index 88b1393..3e7f0dc 100644 (file)
@@ -3,7 +3,7 @@ Version=1.0
 Name=HTML5 HVAC
 Comment=HVAC
 GenericName=HVAC
-Exec=env AFM_ID=webapps-hvac AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-hvac/ /usr/bin/WebAppMgr
+Exec=/usr/bin/WebAppMgr --appid=webapps-hvac --app-install-dir=/usr/lib/wam_apps/html5-hvac/
 Icon=settings
 Terminal=false
 Type=Application
index 9cf5709..f0106db 100644 (file)
@@ -9,10 +9,10 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH} \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=master \
   file://webapps-hvac.desktop \
 "
-SRCREV = "45641bf053eade93cd3590b2286377869bb799cf"
+SRCREV = "e64d69bdad0bb302900ec631b54ad6b6d6dcbacd"
 
 DEPENDS = "nodejs-native"
 
index 17eb563..b3e8e43 100644 (file)
@@ -3,7 +3,7 @@ Version=1.0
 Name=HTML5 Launcher
 Comment=Launcher
 GenericName=Launcher
-Exec=env AFM_ID=launcher AFM_APP_INSTALL_DIR=/usr/lib/wam_apps/html5-launcher/ /usr/bin/WebAppMgr
+Exec=/usr/bin/WebAppMgr --appid=launcher --app-install-dir=/usr/lib/wam_apps/html5-launcher/
 Icon=settings
 Terminal=false
 Type=Application
index ecafd19..52d7077 100644 (file)
@@ -9,10 +9,10 @@ S       = "${WORKDIR}/git"
 B       = "${WORKDIR}/build"
 
 SRC_URI = " \
-  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH} \
+  git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=master \
   file://launcher.desktop \
 "
-SRCREV = "b37179742fac1053ba621cfa12938ec6536cf1f7"
+SRCREV = "cb6b66c3bd94a6ab18cad3ad87c827d4f7e623e9"
 
 DEPENDS = "nodejs-native"
 
index d412bfa..c710c07 100644 (file)
@@ -8,7 +8,7 @@ SRC_URI = "\
 # Needed by catapult
 DEPENDS += "python-six-native python-beautifulsoup4-native python-lxml-native python-html5lib-native python-webencodings-native"
 
-SRCREV_chromium87 = "be0370b198b5862e95efc537630f23e931a6dbe1"
+SRCREV_chromium87 = "c9a66f75a7f40b9fe39e168b596b9743467d7378"
 SRCREV_v8 = "935065d097cce0090bc858746e6aee0919b222de"
 
 CHROMIUM_VERSION = "87.0.4280.88"
index 20c2222..a59871b 100644 (file)
@@ -30,7 +30,7 @@ SRC_URI = "\
     file://WebAppMgr.env \
 "
 S = "${WORKDIR}/git"
-SRCREV = "8dd3f17d374b227d3f8c053621c058cebb68a9e9"
+SRCREV = "f4c2e95afb0ed0cd22095d567fa437a6ccb8c5ab"
 
 PV = "ose55.agl.marlin"