agl-cluster-demo fixes for Kirkstone
authorScott Murray <scott.murray@konsulko.com>
Fri, 15 Apr 2022 17:48:22 +0000 (13:48 -0400)
committerScott Murray <scott.murray@konsulko.com>
Sun, 17 Apr 2022 20:03:17 +0000 (16:03 -0400)
Changes:
- Update "BSD" license declaration in cluster-gauges-qtcompositor
  and cluster-dasboard recipes to now required more specific
  "BSD-3-Clause" after checking in the source tree.
- Make packagegroup-agl-profile-cluster-qtcompositor machine-specific
  to avoid tripping the new check for depending on dynamically renamed
  packages.

Bug-AGL: SPEC-3819

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I24915cd85cb3854b3f9bc7947adda9cb5d42d8a9

recipes-demo/cluster-dashboard/cluster-dashboard_git.bb
recipes-demo/cluster-gauges-qtcompositor/cluster-gauges-qtcompositor_git.bb
recipes-platform/packagegroups/packagegroup-agl-profile-cluster-qtcompositor.bb

index 2f5bbec..0f45d8f 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "AGL demonstration instrument cluster dashboard application"
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-dashboard"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0 & BSD"
+LICENSE     = "Apache-2.0 & BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://app/cluster-gauges.qml;beginline=9;endline=48;md5=54187d50b29429abee6095fe8b7c1a78"
 
index 4210754..74f87ac 100644 (file)
@@ -3,7 +3,7 @@ DESCRIPTION = "AGL HMI Application for demonstrating instrument cluster gauges a
 HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-cluster-demo-gauges"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0 & BSD"
+LICENSE     = "Apache-2.0 & BSD-3-Clause"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
                     file://app/cluster-gauges.qml;beginline=10;endline=49;md5=54187d50b29429abee6095fe8b7c1a78"
 
index ba66b60..0539ae1 100644 (file)
@@ -2,6 +2,8 @@ SUMMARY = "The middleware for AGL Qt5 based cluster qtcompositor"
 DESCRIPTION = "The set of packages required for AGL Qt5 based Cluster Demo Qtcompositor Distribution"
 LICENSE = "MIT"
 
+PACKAGE_ARCH = "${MACHINE_ARCH}"
+
 inherit packagegroup
 
 PACKAGES = "\