Provide patched Wayland-IVI-Extension to work with patched Weston from meta-agl-demo. 27/5627/2
authorAndre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>
Thu, 5 May 2016 16:56:21 +0000 (13:56 -0300)
committerGerrit Code Review <gerrit@172.30.200.200>
Fri, 6 May 2016 13:31:46 +0000 (13:31 +0000)
This change adds support for Wayland IVI Extension 1.9.1 (latest stable release) to work against the
patched weston from meta-agl-demo.
It should not be used when using a stock/unpatched weston.

Wayland-IVI-Extension provides an additional shell plugin for IVI-Shell, along
with command-line tools and demonstration applications.

More info at http://projects.genivi.org/wayland-ivi-extension.

Change-Id: Id74c164eace0cb54d367eda743982bb8baf5d523
Signed-off-by: Andre Moreira Magalhaes (andrunko) <andre.magalhaes@collabora.co.uk>
recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend [new file with mode: 0644]

diff --git a/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend b/recipes-graphics/wayland/wayland-ivi-extension_1.9.1.bbappend
new file mode 100644 (file)
index 0000000..da97895
--- /dev/null
@@ -0,0 +1,28 @@
+FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
+
+ENABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=TRUE \
+    -DINSTALL_ILM_API_TESTS:BOOL=TRUE \
+    "
+
+DISABLE_TEST = "-DBUILD_ILM_API_TESTS:BOOL=FALSE \
+    -DINSTALL_ILM_API_TESTS:BOOL=FALSE \
+    "
+
+PACKAGECONFIG ??= "test"
+PACKAGECONFIG[test] = "${ENABLE_TEST},${DISABLE_TEST},gtest"
+
+SRC_URI_append = "\
+    file://0001-wayland-ivi-extension-patch-for-wl-shell-emulator.patch \
+    file://cmake-find-gtest.patch \
+    file://test-path.patch \
+    "
+
+PACKAGES =+ "${PN}-test"
+
+FILES_${PN}-test = "${libdir}/${PN}/test/*/CTestTestfile.cmake \
+    ${libdir}/${PN}/test/ivi-layermanagement-api-test \
+    ${libdir}/${PN}/test/ivi-input-api-test \
+    "
+FILES_${PN}-dbg += "${libdir}/${PN}/test/.debug"
+
+RDEPENDS_${PN}-test += "cmake"