[cef] Use bundled libwayland instead of the system lib 23/29423/2 16.0.3 pike/16.0.3 pike_16.0.3
authorRoger Zanoni <rzanoni@igalia.com>
Wed, 9 Aug 2023 13:26:18 +0000 (15:26 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sat, 16 Dec 2023 14:41:55 +0000 (14:41 +0000)
For the M108 chromium milestone it would be possible to use the
use_system_libwayland and system_wayland_scanner_path gn args to make
the cef recipe use system wayland and wayland-native dependencies, but
those option got deprecated[1] in newer milestones and chormium defaults
to use the bundled wayland. The more maintainable approach is to use the
third party dependency instead of patching chromium build system.

[1]: https://chromium-review.googlesource.com/c/chromium/src/+/4030440

Bug-AGL: SPEC-4871

Signed-off-by: Roger Zanoni <rzanoni@igalia.com>
Change-Id: I7cb22fcfb1943d6765599544069a379088053a2c
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29423
Tested-by: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
ci-image-build: Jenkins Job builder account
Reviewed-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-wam/cef/cef_git.bb
recipes-wam/wam/files/WebAppMgr-cef.env

index 05d22da..86a0a93 100644 (file)
@@ -56,7 +56,7 @@ OUT_PATH = "${B}/out/Release_GN_${GN_TARGET_CPU}"
 DIST_PATH = "${OUT_PATH}/dist/cef-minimal_${GN_TARGET_CPU}"
 CEF_DATA_PATH = "${datadir}/cef"
 
-DEPENDS:append = " curl clang-native gperf-native wayland wayland-native dbus libcxx compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native"
+DEPENDS:append = " curl clang-native gperf-native dbus libcxx compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native"
 
 do_sync[depends] += "depot-tools-wam-native:do_populate_sysroot"
 do_configure[depends] += "depot-tools-wam-native:do_populate_sysroot"
@@ -188,7 +188,7 @@ GN_DEFINES:append = " \
               ozone_platform_x11=false \
               use_system_minigbm=true \
               use_system_libdrm=true \
-              use_system_libwayland=true \
+              use_system_libwayland=false \
 "
 
 GN_DEFINES:append = " \
index 2aa604c..557f0d4 100644 (file)
@@ -72,11 +72,9 @@ WAM_SWITCHES="\
   --ozone-platform=wayland \
   --no-sandbox \
   --use-viz-fmp-with-timeout=0 \
-  --in-process-gpu \
   --remote-debugging-port=9998 \
   --webos-wam \
   --agl-shell-appid=homescreen \
   --disable-gpu-vsync \
   --ignore-gpu-blocklist \
-  --ignore-gpu-blacklist \
   --allow-file-access-from-files"