Remove qtwebkit from packagegroup-qt5-toolchain-target 29/12729/2
authorStephane Desneux <stephane.desneux@iot.bzh>
Tue, 19 Dec 2017 13:48:39 +0000 (14:48 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 19 Dec 2017 20:36:33 +0000 (20:36 +0000)
When building agl-demo-platform-crosssdk, qtwebkit is pulled and built
due to packagegroup-qt5-toolchain-target.

This commit breaks the dependency between packagegroup-qt5-toolchain-target
and qtwebkit.

Bug-AGL: SPEC-1159

Change-Id: I6e6d705c1407faa3f8ab8fe0d5e1fc39f0b15a6f
Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
recipes-qt/packagegroups/packagegroup-qt5-toolchain-target.bbappend

index 63a7ac4..08afa6c 100644 (file)
@@ -8,3 +8,11 @@ RDEPENDS_${PN} += " \
        qtquickcontrols2-mkspecs \
        qtquickcontrols2-qmlplugins \
 "
+
+# remove dependency on qtwebkit (still added to SDK by packagegroup-qt5-toolchain-target)
+# see SPEC-1159
+RDEPENDS_${PN}_remove = " \
+    qtwebkit-dev \
+    qtwebkit-mkspecs \
+    qtwebkit-qmlplugins \
+"