Update app DEPENDS for new HMI framework 57/11957/2
authorScott Murray <scott.murray@konsulko.com>
Tue, 14 Nov 2017 15:17:42 +0000 (00:17 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 14 Nov 2017 16:15:39 +0000 (16:15 +0000)
Add virtual/libhomescreen and qlibwindowmanager as DEPENDS in
the recipes of apps that have been updated to use the new HMI
framework.

Change-Id: Ic5bcceaa4273612d0eaa7d1762177b4a1077ddfb
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/dashboard/dashboard_git.bb
recipes-demo-hmi/hvac/hvac_git.bb
recipes-demo-hmi/mediaplayer/mediaplayer_git.bb
recipes-demo-hmi/mixer/mixer_git.bb
recipes-demo-hmi/phone/phone_git.bb
recipes-demo-hmi/radio/radio_git.bb
recipes-demo-hmi/settings/settings_git.bb

index 5d02ea2..795e9e1 100644 (file)
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2"
+DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager"
 
 inherit qmake5 aglwgt
index beaaafa..d36696b 100644 (file)
@@ -13,6 +13,6 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2"
+DEPENDS += "qtquickcontrols2 virtual/libhomescreen qlibwindowmanager"
 
 inherit qmake5 aglwgt
index 8a7fd62..e99eb5b 100644 (file)
@@ -12,10 +12,15 @@ SRCREV  = "${AGL_APP_REVISION}"
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt
-
 # build-time dependencies
-DEPENDS += "sqlite3 qtquickcontrols2 qtmultimedia"
+DEPENDS += "sqlite3 \
+            qtquickcontrols2 \
+            qtmultimedia \
+            virtual/libhomescreen \
+            qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
 
 RDEPENDS_${PN} += "qtmultimedia \
                    qtmultimedia-qmlplugins \
index 638dae5..bdbc8db 100644 (file)
@@ -12,7 +12,11 @@ SRCREV  = "${AGL_APP_REVISION}"
 PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
-inherit qmake5 aglwgt
-
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 pulseaudio"
+DEPENDS += "qtquickcontrols2 \
+            pulseaudio \
+            virtual/libhomescreen \
+            qlibwindowmanager \
+"
+
+inherit qmake5 aglwgt
index 6dccd65..fe91d3f 100644 (file)
@@ -13,6 +13,11 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS += "qtquickcontrols2 homescreen libqtappfw qtmultimedia"
+DEPENDS += "qtquickcontrols2 \
+            qtmultimedia \
+            libqtappfw \
+            virtual/libhomescreen \
+            qlibwindowmanager \
+"
 
 inherit qmake5 aglwgt
index 5b599de..8563b01 100644 (file)
@@ -19,6 +19,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS = "qtquickcontrols2 rtl-sdr pulseaudio"
+DEPENDS += "virtual/libhomescreen qlibwindowmanager"
 
 inherit qmake5 aglwgt
 
index 28eee06..e36f0bc 100644 (file)
@@ -14,6 +14,7 @@ S  = "${WORKDIR}/git"
 
 # build-time dependencies
 DEPENDS += "qtquickcontrols2"
+DEPENDS += "virtual/libhomescreen qlibwindowmanager"
 
 # runtime dependencies
 RDEPENDS_${PN} += " \