html5-hvac: create recipe and add to html5 demo 00/23400/1
authorJacobo Aragunde Pérez <jaragunde@igalia.com>
Mon, 16 Dec 2019 17:00:24 +0000 (18:00 +0100)
committerJacobo Aragunde Pérez <jaragunde@igalia.com>
Mon, 16 Dec 2019 17:01:25 +0000 (18:01 +0100)
Bug-AGL: SPEC-2645

Change-Id: Ie4394528f8e960b5a018097a55942865ea5f4554
Signed-off-by: Jacobo Aragunde Pérez <jaragunde@igalia.com>
recipes-demo-hmi/html5-hvac/html5-hvac_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-html5.bb

diff --git a/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb b/recipes-demo-hmi/html5-hvac/html5-hvac_git.bb
new file mode 100644 (file)
index 0000000..d45dc80
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "AGL HTML5 HVAC Application"
+HOMEPAGE    = "https://git.automotivelinux.org/apps/html5-hvac/"
+SECTION     = "apps"
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH}"
+SRCREV = "${AGL_APP_REVISION}"
+
+DEPENDS += " nodejs-native"
+
+inherit aglwgt
+
+do_configure() {
+  cd ${B}
+  npm install
+}
+
+do_aglwgt_package()  {
+  cd ${B}
+  npm run build
+}