Update Flutter demo image to use Flutter homescreen 49/28149/3
authorScott Murray <scott.murray@konsulko.com>
Mon, 21 Nov 2022 07:57:20 +0000 (02:57 -0500)
committerScott Murray <scott.murray@konsulko.com>
Tue, 22 Nov 2022 00:58:30 +0000 (00:58 +0000)
Changes:
- Update Flutter demo image packagegroup to replace the Qt demo
  homescreen and launcher with the new Flutter homescreen.  The
  list of apps to install has been tweaked to drop the Qt HVAC and
  dashboard applications and add the Qt settings, mediaplayer, and
  navigation apps, to better reflect what is likely to be usable for
  ALS and CES.
- A AGL_FLUTTER_RUNTIME variable has been used in the Flutter demo
  image packagegroup to allow potentially switching the Flutter
  packages from release to debug or profile versions.
- Add Flutter homescreen specific weston-ini-conf-flutter package to
  the Flutter demo image.
- Tweak the application display names for the Flutter dashboard and
  HVAC applications to drop the Flutter prefix since they will be the
  only versions present in the Flutter demo image.

Bug-AGL: SPEC-4615

Change-Id: Iec1c139b72cbd953420f23484942ad255080f4f7
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo/flutter-dashboard/flutter-dashboard_git.bb
recipes-demo/flutter-hvac/flutter-hvac_git.bb
recipes-platform/images/agl-ivi-demo-platform-flutter.bb
recipes-platform/packagegroups/packagegroup-agl-demo-platform-flutter.bb

index d44b30c..e7297c3 100644 (file)
@@ -31,16 +31,11 @@ FLUTTER_BUILD_ARGS = "bundle -v"
 #########
 AGL_APP_TEMPLATE = "agl-app-flutter"
 AGL_APP_ID = "dashboard_app"
-AGL_APP_NAME = "Flutter Dashboard"
-
-
+AGL_APP_NAME = "Dashboard"
 
 do_install:append() {
     install -d ${D}${sysconfdir}/xdg/AGL
     install -m 0644 ${WORKDIR}/dashboard_config.yaml ${D}${sysconfdir}/xdg/AGL/
-
-
-    
 }
 
 FILES:${PN} += "${sysconfdir}/xdg/AGL"
index a206241..cfd0522 100644 (file)
@@ -30,7 +30,7 @@ FLUTTER_BUILD_ARGS = "bundle -v"
 #########
 AGL_APP_TEMPLATE = "agl-app-flutter"
 AGL_APP_ID = "flutter_hvac"
-AGL_APP_NAME = "Flutter Hvac"
+AGL_APP_NAME = "HVAC"
 
 do_install:append() {
     install -d ${D}${sysconfdir}/xdg/AGL
index 7884a2d..097c1fd 100644 (file)
@@ -5,5 +5,6 @@ DESCRIPTION = "AGL Flutter based Demo Platform image"
 # add packages for demo platform (include demo apps) here
 IMAGE_INSTALL:append = " \
     packagegroup-agl-demo-platform-flutter \
+    weston-ini-conf-flutter \
 "
 
index 2ab6882..76bff18 100644 (file)
@@ -13,22 +13,25 @@ PACKAGES = "\
 RDEPENDS:${PN} += "\
     packagegroup-agl-image-ivi \
     packagegroup-agl-profile-graphical-qt5 \
-    packagegroup-hmi-framework \
     packagegroup-agl-demo \
     "
 
+AGL_FLUTTER_RUNTIME ?= "runtimerelease"
+
 AGL_APPS = " \
-    hvac \
-    dashboard \
-    flutter-dashboard \
-    flutter-hvac \
-    flutter-nav \
-    flutter-mediaplayer \
+    settings \
+    mediaplayer \
+    ondemandnavi \
+    flutter-dashboard-${AGL_FLUTTER_RUNTIME} \
+    flutter-hvac-${AGL_FLUTTER_RUNTIME} \
+    flutter-mediaplayer-${AGL_FLUTTER_RUNTIME} \
+    flutter-nav-${AGL_FLUTTER_RUNTIME} \
     "
 
 RDEPENDS:${PN}:append = " \
-    flutter-auto-runtimerelease \
-    launcher \
+    agl-compositor \
+    flutter-auto-${AGL_FLUTTER_RUNTIME} \
+    flutter-homescreen-${AGL_FLUTTER_RUNTIME} \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-devel', 'unzip mpc' , '', d)} \