Introduce new 4A audio framework conditionnaly to feature 'agl-audio-4a-framework' 67/11867/3
authorStephane Desneux <stephane.desneux@iot.bzh>
Sat, 11 Nov 2017 18:12:32 +0000 (19:12 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Sun, 12 Nov 2017 06:32:51 +0000 (06:32 +0000)
If feature 'agl-audio-4a-framework' is set by aglsetup, the new 4A (AGL Advanced Audio Agent)
framework will be pulled in demo.

Otherwise (by default), the legacy 'audiomanager' package is pulled in.

Change-Id: I62b62025be6589e3b5dd0b964830e431ffa56e8c
Signed-off-by: Stephane Desneux <stephane.desneux@iot.bzh>
recipes-core/packagegroups/packagegroup-ivi-common-core-multimedia.bbappend
recipes-platform/packagegroups/packagegroup-agl-demo.bb

index 186280e..3f1cc28 100644 (file)
@@ -19,10 +19,16 @@ HOMESCREEN-OLD = "homescreen"
 # packages from hmi-framework aka homescreen-2017
 HOMESCREEN-NEW = "packagegroup-hmi-framework packagegroup-hmi-framework-dev"
 
+# old audio package
+AUDIO-OLD = "audiomanager"
+# packages from new 4A framework
+AUDIO-NEW = "packagegroup-agl-audio"
+
 RDEPENDS_${PN} += "\
     packagegroup-agl-appfw \
     libqtappfw \
     ${@bb.utils.contains('DISTRO_FEATURES', 'agl-hmi-framework', '${HOMESCREEN-NEW}', '${HOMESCREEN-OLD}', d)} \
+    ${@bb.utils.contains('DISTRO_FEATURES', 'agl-audio-4a-framework', '${AUDIO-NEW}', '${AUDIO-OLD}', d)} \
     udisks \
     ${SMARTDEVICELINK} \
     "