Add D-Bus configuration of navigation service 49/12449/4
authorNaoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
Tue, 12 Dec 2017 01:52:01 +0000 (10:52 +0900)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 18 Dec 2017 22:40:12 +0000 (22:40 +0000)
Add the D-Bus configuration provided by the navigation service.
Currently navigation app provides API, but this is transient measure.
In the future this configuration will be moved to the navigation service.

Change-Id: I2eeb13cf3e792c00474cc7999078ec6ae6c5a137
Signed-off-by: Naoto Yamaguchi <i33399_YAMAGUCHI@aisin-aw.co.jp>
recipes-demo-hmi/navigation/navigation/org.agl.naviapi.conf [new file with mode: 0644]
recipes-demo-hmi/navigation/navigation_git.bb

diff --git a/recipes-demo-hmi/navigation/navigation/org.agl.naviapi.conf b/recipes-demo-hmi/navigation/navigation/org.agl.naviapi.conf
new file mode 100644 (file)
index 0000000..7f4d85f
--- /dev/null
@@ -0,0 +1,15 @@
+<!DOCTYPE busconfig PUBLIC
+"-//freedesktop//DTD D-BUS Bus Configuration 1.0//EN"
+"http://www.freedesktop.org/standards/dbus/1.0/busconfig.dtd">
+<busconfig>
+       <policy context="default">
+               <!-- Allow everyone to talk to main service. We'll later add an agent to
+                    only share the location if user allows it. -->
+               <allow send_interface="org.agl.naviapi"/>
+       </policy>
+
+       <policy user="root">
+               <!-- Allow root to own the name on the bus -->
+               <allow own="org.agl.naviapi"/>
+       </policy>
+</busconfig>
index 822405e..9215e55 100644 (file)
@@ -18,10 +18,11 @@ RDEPENDS_${PN} = " flite openjtalk glib-2.0 freetype sqlite3 wayland zlib expat
 RDEPENDS_${PN} += " agl-service-navigation "
 
 
-SRCREV="acbb9ea0678bd2f21f268000332a4786e87fb3f6"
+SRCREV="051e504db0e30d3160d63ef67b0225227e5da94d"
 SRC_URI="git://github.com/AGLExport/gpsnavi.git;branch=agl \
          file://download_mapdata_jp.sh \
          file://download_mapdata_uk.sh \
+         file://org.agl.naviapi.conf \
 "
 
 RPROVIDES_${PN} = "virtual/navigation"
@@ -40,6 +41,9 @@ do_install_append() {
    install -m 0755 ${WORKDIR}/download_mapdata_jp.sh ${D}/usr/AGL/apps/
    install -m 0755 ${WORKDIR}/download_mapdata_uk.sh ${D}/usr/AGL/apps/
 
+   install -d ${D}/etc/dbus-1/session.d/
+   install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
+
    install -d ${D}/var/mapdata
 }