Add window-management-client-grpc 60/28560/3
authorMarius Vlad <marius.vlad@collabora.com>
Fri, 3 Mar 2023 11:13:59 +0000 (13:13 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 20 Mar 2023 10:29:58 +0000 (10:29 +0000)
This adds a recipe for window-management-client-grpc for testing out the
gRPC interface. This client will talk with the compositor indirectly,
using the gRPC interface exposed by the grpc-proxy helper client.

Bug-AGL: SPEC-4673
Change-Id: Ib1a9d14a3bd41ea64180494962f97f0d5b557c09
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb

diff --git a/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb b/recipes-demo/window-management-client-grpc/window-management-client-grpc_git.bb
new file mode 100644 (file)
index 0000000..9dabbaa
--- /dev/null
@@ -0,0 +1,28 @@
+SUMMARY     = "Window management gRPC application"
+DESCRIPTION = "AGL demonstration of window management using gRPC"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "qtbase qtdeclarative qtquickcontrols2 qtwayland \
+          qtwayland-native libqtappfw grpc grpc-native \
+          "
+
+PV = "2.0+git${SRCPV}"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/src/window-management-client-grpc.git;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "8b057267c4180e5648b6636f4b5b1de07f627977"
+
+S  = "${WORKDIR}/git"
+
+inherit  meson pkgconfig agl-app
+
+AGL_APP_NAME = "window-management-client-grpc"
+
+do_install:append() {
+    install -d ${D}${sysconfdir}/xdg/AGL/window-management-client-grpc
+}
+
+RDEPENDS:${PN} += "libqtappfw qtbase-qmlplugins"
index 307c428..c490042 100644 (file)
@@ -26,6 +26,7 @@ AGL_APPS = " \
     messaging \
     phone \
     radio \
+    window-management-client-grpc \
     "
 
 RDEPENDS:${PN}:append = " \