Revert "Remove Deprecated recipes homescreen" 19/16119/1
authorMatt Porter <mporter@konsulko.com>
Tue, 14 Aug 2018 14:54:15 +0000 (10:54 -0400)
committerMatt Porter <mporter@konsulko.com>
Tue, 14 Aug 2018 14:57:00 +0000 (10:57 -0400)
This reverts commit 8d853962f123472f0e7217789f80c10c0191ade5.

homescreen recipe is required by the recently merged switch from
homescreen-2017 to homescreen.

Change-Id: I53e3d7378bf2f2fbe2953d821676dfeda12ff034
Signed-off-by: Matt Porter <mporter@konsulko.com>
recipes-demo-hmi/homescreen/homescreen_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/homescreen/homescreen_git.bb b/recipes-demo-hmi/homescreen/homescreen_git.bb
new file mode 100644 (file)
index 0000000..f9b02e9
--- /dev/null
@@ -0,0 +1,29 @@
+SUMMARY     = "AGL Home Screen Application"
+DESCRIPTION = "AGL Home Screen Application build with recipe method"
+HOMEPAGE    = "http://docs.automotivelinux.org"
+LICENSE     = "Apache-2.0"
+SECTION     = "apps"
+LIC_FILES_CHKSUM = "file://homescreen/LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+DEPENDS = "\
+        qtbase \
+        qtdeclarative \
+        qtquickcontrols2 \
+        pulseaudio \
+        agl-service-homescreen-2017 \
+        agl-service-windowmanager-2017 \
+        agl-service-weather \
+        libqtappfw \
+        qlibwindowmanager \
+        virtual/libhomescreen \
+"
+
+inherit qmake5 systemd pkgconfig aglwgt
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/homescreen;protocol=https;branch=${AGL_BRANCH}"
+SRCREV  = "${AGL_APP_REVISION}"
+
+PV      = "1.0+git${SRCPV}"
+S       = "${WORKDIR}/git/"
+
+PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"