poiapp-api-key: Add client ID 45/19045/3
authorScott Murray <scott.murray@konsulko.com>
Mon, 17 Dec 2018 01:51:25 +0000 (20:51 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 20 Dec 2018 21:10:18 +0000 (21:10 +0000)
Somehow in my original testing the POI app was working even though
the client ID was not being added to /etc/poikey as the first line.
Add a POIAPP_CLIENT_ID variable to go with POIAPP_API_KEY, and write
them both to the file. As well, mark the package as platform
independent, as it contains just a text configuration file.

Change-Id: Iab5d6aa44007c61457697882d9a2ece12f984acf
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/poiapp-api-key_1.0.bb

index ad6546f..4d53fdb 100755 (executable)
@@ -9,9 +9,13 @@ do_fetch[noexec] = "1"
 do_unpack[noexec] = "1"
 do_compile[noexec] = "1"
 
+POIAPP_CLIENT_ID ?= ""
 POIAPP_API_KEY ?= ""
 
 do_install () {
     install -d ${D}${sysconfdir}
-    echo "${POIAPP_API_KEY}" > ${D}${sysconfdir}/poikey
+    echo "${POIAPP_CLIENT_ID}" > ${D}${sysconfdir}/poikey
+    echo "${POIAPP_API_KEY}" >> ${D}${sysconfdir}/poikey
 }
+
+PACKAGE_ARCH = "all"