ondemandnavi-config: switch to allarch class 61/21761/1
authorScott Murray <scott.murray@konsulko.com>
Thu, 27 Jun 2019 01:01:11 +0000 (21:01 -0400)
committerScott Murray <scott.murray@konsulko.com>
Thu, 27 Jun 2019 01:02:45 +0000 (21:02 -0400)
Switch from setting PACKAGE_ARCH to inheriting the allarch class in the
ondemandnavi-config recipe.  This fixes a failure when building an image
with the ondemandnavi application that seems due to a change between
rocko and thud.

Bug-AGL: SPEC-2576

Change-Id: I5c99571db72e600ae0da05304e46c503466985d2
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/ondemandnavi-config_1.0.bb [changed mode: 0755->0644]

old mode 100755 (executable)
new mode 100644 (file)
index 784341e..212971f
@@ -9,17 +9,13 @@ LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Proprietary;md5=0557f9d92cf58f2
 SRC_URI = "file://naviconfig.ini \
           "
 
-S = "${WORKDIR}"
+inherit allarch
 
 MAPBOX_ACCESS_TOKEN ?= "Please set mapbox access token"
 
+do_compile[noexec] = "1"
+
 do_install () {
-    install -d ${D}${sysconfdir}
-    install -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}
+    install -D -m 644 ${WORKDIR}/naviconfig.ini ${D}${sysconfdir}/naviconfig.ini
     sed -i -e 's/MAPBOX_ACCESS_TOKEN/${MAPBOX_ACCESS_TOKEN}/' ${D}${sysconfdir}/naviconfig.ini
 }
-
-PACKAGE_ARCH = "all"
-
-PACKAGES = "${PN}"
-FILES_${PN} = "/etc/naviconfig.ini"