qt: enable upgrade to 5.8 61/9361/2
authorMartin Kelly <mkelly@xevo.com>
Tue, 25 Apr 2017 20:13:57 +0000 (13:13 -0700)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 16 May 2017 05:07:51 +0000 (05:07 +0000)
Drop patches and bbappends that no longer apply. I audited these to
verify that they already exist upstream, and I believe we are OK.

Change-Id: I83f8334539d5542c7632b45e230d53915fdf18bf
Depends-On: I024b757d16e5891382f4286dadee3315163a79d5
Signed-off-by: Martin Kelly <mkelly@xevo.com>
recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
recipes-qt/qt5/qtmultimedia/0001-GStreamer-support-cover-art.patch [deleted file]
recipes-qt/qt5/qtmultimedia/0001-GStreamer-support-date-time-type-in-metadata.patch [deleted file]
recipes-qt/qt5/qtmultimedia_%.bbappend
recipes-qt/qt5/qtwayland-native_%.bbappend [deleted file]
recipes-qt/qt5/qtwayland/0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch [deleted file]
recipes-qt/qt5/qtwayland_%.bbappend

index 8eef9ce..ce7bda7 100644 (file)
@@ -18,7 +18,6 @@ RDEPENDS_${PN} += "\
     qtbase-staticdev \
     qtbase-tools \
     qtdeclarative \
-    qtdeclarative-plugins \
     qtdeclarative-qmlplugins \
     qtdeclarative-tools \
     qtwayland \
diff --git a/recipes-qt/qt5/qtmultimedia/0001-GStreamer-support-cover-art.patch b/recipes-qt/qt5/qtmultimedia/0001-GStreamer-support-cover-art.patch
deleted file mode 100644 (file)
index 8e64490..0000000
+++ /dev/null
@@ -1,54 +0,0 @@
-From 9bdc7c84eea0ff66c937d5f62ffed249321c3c35 Mon Sep 17 00:00:00 2001
-From: Tasuku Suzuki <tasuku.suzuki@qt.io>
-Date: Sun, 24 Jul 2016 00:23:36 +0900
-Subject: [PATCH] GStreamer: support cover art
-
-Change-Id: I05987f578a40c23dc2eb6f3e6a7f76d11f704214
-Reviewed-by: Yoann Lopes <yoann.lopes@qt.io>
----
- src/gsttools/qgstutils.cpp                               | 16 ++++++++++++++++
- .../gstreamer/mediaplayer/qgstreamermetadataprovider.cpp |  1 +
- 2 files changed, 17 insertions(+)
-
-diff --git a/src/gsttools/qgstutils.cpp b/src/gsttools/qgstutils.cpp
-index 831ba96..a2b3507 100644
---- a/src/gsttools/qgstutils.cpp
-+++ b/src/gsttools/qgstutils.cpp
-@@ -141,6 +141,22 @@ static void addTagToMap(const GstTagList *list,
-                 }
-                 if (!map->contains("year") && year > 0)
-                     map->insert("year", year);
-+            } else if (G_VALUE_TYPE(&val) == GST_TYPE_SAMPLE) {
-+                GstSample *sample = (GstSample *)g_value_get_boxed(&val);
-+                GstCaps* caps = gst_sample_get_caps(sample);
-+                if (caps && !gst_caps_is_empty(caps)) {
-+                    GstStructure *structure = gst_caps_get_structure(caps, 0);
-+                    const gchar *name = gst_structure_get_name(structure);
-+                    if (QByteArray(name).startsWith("image/")) {
-+                        GstBuffer *buffer = gst_sample_get_buffer(sample);
-+                        if (buffer) {
-+                            GstMapInfo info;
-+                            gst_buffer_map(buffer, &info, GST_MAP_READ);
-+                            map->insert(QByteArray(tag), QImage::fromData(info.data, info.size, name));
-+                            gst_buffer_unmap(buffer, &info);
-+                        }
-+                    }
-+                }
- #endif
-             } else if (G_VALUE_TYPE(&val) == GST_TYPE_FRACTION) {
-                 int nom = gst_value_get_fraction_numerator(&val);
-diff --git a/src/plugins/gstreamer/mediaplayer/qgstreamermetadataprovider.cpp b/src/plugins/gstreamer/mediaplayer/qgstreamermetadataprovider.cpp
-index 074f8ad..01103d6 100644
---- a/src/plugins/gstreamer/mediaplayer/qgstreamermetadataprovider.cpp
-+++ b/src/plugins/gstreamer/mediaplayer/qgstreamermetadataprovider.cpp
-@@ -93,6 +93,7 @@ static const QGstreamerMetaDataKeyLookup *qt_gstreamerMetaDataKeys()
-         //metadataKeys->insert(0, QMediaMetaData::CoverArtUrlSmall);
-         //metadataKeys->insert(0, QMediaMetaData::CoverArtUrlLarge);
-+        metadataKeys->insert(GST_TAG_PREVIEW_IMAGE, QMediaMetaData::CoverArtImage);
-         // Image/Video
-         metadataKeys->insert("resolution", QMediaMetaData::Resolution);
--- 
-2.7.4
-
diff --git a/recipes-qt/qt5/qtmultimedia/0001-GStreamer-support-date-time-type-in-metadata.patch b/recipes-qt/qt5/qtmultimedia/0001-GStreamer-support-date-time-type-in-metadata.patch
deleted file mode 100644 (file)
index 252838f..0000000
+++ /dev/null
@@ -1,51 +0,0 @@
-From d0ac492e3023545adad8008a3ebcac2a297dc783 Mon Sep 17 00:00:00 2001
-From: Tasuku Suzuki <tasuku.suzuki@qt.io>
-Date: Sun, 24 Jul 2016 00:23:10 +0900
-Subject: [PATCH] GStreamer: support date time type in metadata
-
-Change-Id: Ica57abfc0a60b401be88662483d35699d4f76321
-Reviewed-by: Yoann Lopes <yoann.lopes@qt.io>
----
- src/gsttools/qgstutils.cpp | 19 +++++++++++++++++++
- 1 file changed, 19 insertions(+)
-
-diff --git a/src/gsttools/qgstutils.cpp b/src/gsttools/qgstutils.cpp
-index b5299f1..831ba96 100644
---- a/src/gsttools/qgstutils.cpp
-+++ b/src/gsttools/qgstutils.cpp
-@@ -40,6 +40,7 @@
- #include "qgstutils_p.h"
- #include <QtCore/qdatetime.h>
-+#include <QtCore/qtimezone.h>
- #include <QtCore/qdir.h>
- #include <QtCore/qbytearray.h>
- #include <QtCore/qvariant.h>
-@@ -123,6 +124,24 @@ static void addTagToMap(const GstTagList *list,
-                     if (!map->contains("year"))
-                         map->insert("year", year);
-                 }
-+#if GST_CHECK_VERSION(1,0,0)
-+            } else if (G_VALUE_TYPE(&val) == GST_TYPE_DATE_TIME) {
-+                const GstDateTime *dateTime = (const GstDateTime *)g_value_get_boxed(&val);
-+                int year = gst_date_time_has_year(dateTime) ? gst_date_time_get_year(dateTime) : 0;
-+                int month = gst_date_time_has_month(dateTime) ? gst_date_time_get_month(dateTime) : 0;
-+                int day = gst_date_time_has_day(dateTime) ? gst_date_time_get_day(dateTime) : 0;
-+                if (gst_date_time_has_time(dateTime)) {
-+                    int hour = gst_date_time_get_hour(dateTime);
-+                    int minute = gst_date_time_get_minute(dateTime);
-+                    int second = gst_date_time_get_second(dateTime);
-+                    float tz = gst_date_time_get_time_zone_offset(dateTime);
-+                    map->insert(QByteArray(tag), QDateTime(QDate(year,month,day), QTime(hour, minute, second), QTimeZone(tz * 60 * 60)));
-+                } else if (year > 0 && month > 0 && day > 0) {
-+                    map->insert(QByteArray(tag), QDate(year,month,day));
-+                }
-+                if (!map->contains("year") && year > 0)
-+                    map->insert("year", year);
-+#endif
-             } else if (G_VALUE_TYPE(&val) == GST_TYPE_FRACTION) {
-                 int nom = gst_value_get_fraction_numerator(&val);
-                 int denom = gst_value_get_fraction_denominator(&val);
--- 
-2.7.4
-
index 76e3db5..1f3693b 100644 (file)
@@ -4,7 +4,5 @@ PACKAGECONFIG_append = " gstreamer"
 
 SRC_URI_append = " \
     file://0001-metadata-image-support-with-the-data-URL-scheme-for-.patch \
-    file://0001-GStreamer-support-date-time-type-in-metadata.patch \
-    file://0001-GStreamer-support-cover-art.patch \
     file://0001-GStreamer-support-cover-art-image.patch \
     "
diff --git a/recipes-qt/qt5/qtwayland-native_%.bbappend b/recipes-qt/qt5/qtwayland-native_%.bbappend
deleted file mode 100644 (file)
index 5128d0e..0000000
+++ /dev/null
@@ -1 +0,0 @@
-# QT_MODULE_BRANCH = "5.4"
diff --git a/recipes-qt/qt5/qtwayland/0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch b/recipes-qt/qt5/qtwayland/0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch
deleted file mode 100644 (file)
index 67c4bba..0000000
+++ /dev/null
@@ -1,31 +0,0 @@
-From f7947e9a0e6ae99e8fd0ab3c9176885f724ac87d Mon Sep 17 00:00:00 2001
-From: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
-Date: Tue, 19 Jul 2016 12:14:26 -0500
-Subject: [PATCH] Avoid attaching NULL buffer while hiding EGL windows
-
-Incremental fix for QTBUG-46921. Destroying the callback for NULL surface is not
-working all the time. If the window is hidden by destroying the EGL surface
-and hence setting the NULL buffer is no longer required.
-
-Task-number:QTBUG-47902
-Signed-off-by: Prabhu Sundararaj <prabhu.sundararaj@nxp.com>
----
- src/client/qwaylandwindow.cpp | 2 --
- 1 file changed, 2 deletions(-)
-
-diff --git a/src/client/qwaylandwindow.cpp b/src/client/qwaylandwindow.cpp
-index 2dd58e8..24b5653 100644
---- a/src/client/qwaylandwindow.cpp
-+++ b/src/client/qwaylandwindow.cpp
-@@ -312,8 +312,6 @@ void QWaylandWindow::setVisible(bool visible)
-         QPointer<QWaylandWindow> deleteGuard(this);
-         QWindowSystemInterface::flushWindowSystemEvents();
-         if (!deleteGuard.isNull()) {
--            attach(static_cast<QWaylandBuffer *>(0), 0, 0);
--            commit();
-             if (mBackingStore) {
-                 mBackingStore->hidden();
-             }
--- 
-2.7.4
-
index baaf114..ed9e374 100644 (file)
@@ -22,7 +22,6 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 
 SRC_URI_append = "\
     file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
-    file://0001-Avoid-attaching-NULL-buffer-while-hiding-EGL-windows.patch \
     "
 SRC_URI_append_checkforkrogoth = "\
     file://disable_xcomposite_egl_qt_wayland_client_buffer_integration.patch \