Add als-meter-demo recipe 73/11573/2
authorzheng_wenlong <wenlong_zheng@nexty-ele.com>
Fri, 27 Oct 2017 04:47:58 +0000 (13:47 +0900)
committerZheng Wenlong <wenlong_zheng@nexty-ele.com>
Mon, 30 Oct 2017 01:17:31 +0000 (01:17 +0000)
    Add a recipe for als-meter-demo application,
    which use steering-wheel-service to display engine information.

Change-Id: Iaac39a357ad227ddff5d9e0e201ee41ef6cf4f14
Signed-off-by: zheng_wenlong <wenlong_zheng@nexty-ele.com>
recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb [new file with mode: 0644]

diff --git a/recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb b/recipes-demo-hmi/als-meter-demo/als-meter-demo_git.bb
new file mode 100644 (file)
index 0000000..40eadd0
--- /dev/null
@@ -0,0 +1,21 @@
+SUMMARY     = "Demo app for streeting-wheel"
+DESCRIPTION = "AGL demo app for streeting-wheel"
+HOMEPAGE    = "http://192.168.160.148/shenhui/als-meter-demo-release"
+SECTION     = "apps"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/als-meter-demo;protocol=https;branch=master"
+SRCREV = "aa15796ee333339673a8b4ac5468050a9a5b7f93"
+
+PV = "0.1+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS += "qtquickcontrols2 opencv"
+
+# runtime dependencies
+RDEPENDS_${PN} += "agl-service-steering-wheel"
+
+inherit qmake5 aglwgt