Update html5 widget recipes 08/24608/1
authorScott Murray <scott.murray@konsulko.com>
Tue, 2 Jun 2020 16:49:23 +0000 (12:49 -0400)
committerScott Murray <scott.murray@konsulko.com>
Tue, 2 Jun 2020 16:49:23 +0000 (12:49 -0400)
Remove aglwgt task over-rides so that autobuild scripts will be used,
and clean up DEPENDS definitions to match OE style recommendation.

Bug-AGL: SPEC-2049, SPEC-3397

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I4cc54aa272060ec8130ea253164a99cd00ad5c44

recipes-demo-hmi/html5-dashboard/html5-dashboard_git.bb
recipes-demo-hmi/html5-homescreen/html5-homescreen_git.bb
recipes-demo-hmi/html5-hvac/html5-hvac_git.bb
recipes-demo-hmi/html5-launcher/html5-launcher_git.bb
recipes-demo-hmi/html5-mediaplayer/html5-mediaplayer_git.bb
recipes-demo-hmi/html5-mixer/html5-mixer_git.bb
recipes-demo-hmi/html5-settings/html5-settings_git.bb

index 534bd2d..ac87475 100644 (file)
@@ -10,16 +10,6 @@ S       = "${WORKDIR}/git/"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-dashboard;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
 
 inherit aglwgt
-
-do_configure() {
-  cd ${B}
-  npm install
-}
-
-do_aglwgt_package()  {
-  cd ${B}
-  npm run build
-}
index 6895626..37ca707 100644 (file)
@@ -10,16 +10,6 @@ S       = "${WORKDIR}/git/"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-homescreen;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
 
 inherit aglwgt
-
-do_configure() {
-  cd ${B}
-  npm install
-}
-
-do_aglwgt_package()  {
-  cd ${B}
-  npm run build
-}
index d45dc80..7fc89ae 100644 (file)
@@ -10,16 +10,6 @@ S       = "${WORKDIR}/git/"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-hvac;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
 
 inherit aglwgt
-
-do_configure() {
-  cd ${B}
-  npm install
-}
-
-do_aglwgt_package()  {
-  cd ${B}
-  npm run build
-}
index ce8a1d1..47760f6 100644 (file)
@@ -10,16 +10,6 @@ S       = "${WORKDIR}/git/"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-launcher;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
 
 inherit aglwgt
-
-do_configure() {
-  cd ${B}
-  npm install
-}
-
-do_aglwgt_package()  {
-  cd ${B}
-  npm run build
-}
index 2b14376..a87b9bc 100644 (file)
@@ -10,16 +10,6 @@ S       = "${WORKDIR}/git/"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mediaplayer;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
 
 inherit aglwgt
-
-do_configure() {
-  cd ${B}
-  npm install
-}
-
-do_aglwgt_package()  {
-  cd ${B}
-  npm run build
-}
index 09fa249..97b1195 100644 (file)
@@ -10,6 +10,6 @@ S       = "${WORKDIR}/git/"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-mixer;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
 
 inherit aglwgt
index dea1ec3..a167b14 100644 (file)
@@ -10,16 +10,6 @@ S       = "${WORKDIR}/git/"
 SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/html5-settings;protocol=https;branch=${AGL_BRANCH}"
 SRCREV = "${AGL_APP_REVISION}"
 
-DEPENDS += " nodejs-native"
+DEPENDS = "nodejs-native"
 
 inherit aglwgt
-
-do_configure() {
-  cd ${B}
-  npm install
-}
-
-do_aglwgt_package()  {
-  cd ${B}
-  npm run build
-}