weston-terminal: Rename to correct appid 58/27458/3
authorMarius Vlad <marius.vlad@collabora.com>
Thu, 5 May 2022 14:25:21 +0000 (17:25 +0300)
committerMarius Vlad <marius.vlad@collabora.com>
Thu, 5 May 2022 15:05:37 +0000 (18:05 +0300)
With weston 10, we also update the terminal appid, so we need to update
our .desktop file to reflect that.

Bug-AGL: SPEC-4358
Signed-off-by: Marius Vlad <marius.vlad@collabora.com>
Change-Id: I7a090f78a76680ead5a0514c66aae3ea9a0d9d5f

recipes-graphics/wayland/weston-terminal-conf.bb
recipes-graphics/wayland/weston-terminal-conf/org.freedesktop.weston.wayland-terminal.desktop [moved from recipes-graphics/wayland/weston-terminal-conf/weston-terminal.desktop with 100% similarity]

index 4bf864f..abc23cb 100644 (file)
@@ -3,14 +3,14 @@ LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/Apache-2.0;md5=89aea4e17d99a7cacdbeed46a0096b10"
 
 SRC_URI = " \
-    file://weston-terminal.desktop \
+    file://org.freedesktop.weston.wayland-terminal.desktop \
 "
 
 inherit allarch
 
 do_install() {
     install -d ${D}${datadir}/applications
-    install -m 0644 ${WORKDIR}/weston-terminal.desktop ${D}${datadir}/applications
+    install -m 0644 ${WORKDIR}/org.freedesktop.weston.wayland-terminal.desktop ${D}${datadir}/applications
 }
 
 FILES:${PN} = "${datadir}/applications"