CEF and icu: fix CEF dependencies and icu package 86/29486/6
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Tue, 28 Nov 2023 21:28:42 +0000 (22:28 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 30 Nov 2023 11:25:13 +0000 (11:25 +0000)
This patchset fixes the html5 app build in CI by adding
missing dependenies to CEF but also to extend the
icu package with .dat file generation which was turned off
upstream in YP poky git 754866f32bfc1e3986199b353f037536f326ae77 .
https://git.yoctoproject.org/poky/commit/meta/recipes-support/icu?id=754866f32bfc1e3986199b353f037536f326ae77
Did break node here due to the missing .dat file.

v2: add ca-certificates-native and export path to it

Bug-AGL: SPEC-4980
Bug-AGL: SPEC-4994
Change-Id: Iec50431c1ee5417653e307dd34cd05b7d7bfa0ff
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
Reviewed-on: https://gerrit.automotivelinux.org/gerrit/c/AGL/meta-agl-demo/+/29486
Tested-by: Jenkins Job builder account
ci-image-boot-test: Jenkins Job builder account
ci-image-build: Jenkins Job builder account

recipes-support/icu/icu_70.1.bbappend [new file with mode: 0644]
recipes-support/icu/icu_70.1_agldemo.inc [new file with mode: 0644]
recipes-wam/cef/cef_git.bb

diff --git a/recipes-support/icu/icu_70.1.bbappend b/recipes-support/icu/icu_70.1.bbappend
new file mode 100644 (file)
index 0000000..b30ade4
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'icu_70.1_agldemo.inc', '', d)}
\ No newline at end of file
diff --git a/recipes-support/icu/icu_70.1_agldemo.inc b/recipes-support/icu/icu_70.1_agldemo.inc
new file mode 100644 (file)
index 0000000..957fe08
--- /dev/null
@@ -0,0 +1,27 @@
+PACKAGECONFIG:append = " make-icudata"
+
+do_compile:append () {
+    # just adding below does not enforce a full rebuild
+    # thus force rebuild and investigate
+    echo "new"
+}
+
+do_make_icudata:class-native () {
+    ${@bb.utils.contains('PACKAGECONFIG', 'make-icudata', '', 'exit 0', d)}
+    cd ${S}
+    rm -rf data
+    cp -a ${WORKDIR}/data .
+    AR='${BUILD_AR}' \
+    CC='${BUILD_CC}' \
+    CPP='${BUILD_CPP}' \
+    CXX='${BUILD_CXX}' \
+    RANLIB='${BUILD_RANLIB}' \
+    CFLAGS='${BUILD_CFLAGS}' \
+    CPPFLAGS='${BUILD_CPPFLAGS}' \
+    CXXFLAGS='${BUILD_CXXFLAGS}' \
+    LDFLAGS='${BUILD_LDFLAGS}' \
+    ICU_DATA_FILTER_FILE=${WORKDIR}/filter.json \
+    ./runConfigureICU Linux --with-data-packaging=archive
+    oe_runmake
+    install -Dm644 ${S}/data/out/icudt${ICU_MAJOR_VER}l.dat ${S}/data/in/icudt${ICU_MAJOR_VER}l.dat
+}
index 67ab694..ee47d2c 100644 (file)
@@ -1,6 +1,6 @@
 require gn-utils.inc
 
-inherit qemu
+inherit qemu python3native
 
 LICENSE = "Apache-2.0 & BSD-3-Clause & LGPL-2.0-only & LGPL-2.1-only"
 
@@ -88,7 +88,7 @@ OUT_PATH = "${B}/out/Release_GN_${GN_TARGET_ARCH_NAME}"
 DIST_PATH = "${OUT_PATH}/dist/cef-minimal_${GN_TARGET_ARCH_NAME}"
 CEF_DATA_PATH = "${datadir}/cef"
 
-DEPENDS:append = " curl clang clang-native gperf-native dbus libcxx libcxx-native libpng libxslt jpeg compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native compiler-rt compiler-rt-native"
+DEPENDS:append = " ca-certificates-native curl clang clang-native gperf-native dbus libcxx libcxx-native libpng libxslt jpeg jpeg-native compiler-rt libxkbcommon nss nss-native atk at-spi2-atk libdrm pango cairo virtual/egl qemu-native pciutils glib-2.0 pkgconfig-native pulseaudio xz-native compiler-rt compiler-rt-native"
 
 do_sync[depends] += "depot-tools-wam-native:do_populate_sysroot"
 do_configure[depends] += "depot-tools-wam-native:do_populate_sysroot"
@@ -301,7 +301,7 @@ do_configure () {
     export GCLIENT_PY3=1
     export PATH="${DEPOT_TOOLS_DIR}:$PATH"
     export GN_DEFINES="${GN_DEFINES}"
-
+    export SSL_CERT_DIR="$OECORE_NATIVE_SYSROOT/etc/ssl/certs/"
     cd ${S}
     python3 ./build/linux/unbundle/replace_gn_files.py --system-libraries ${GN_UNBUNDLE_LIBS}