unicens-config: Add udev rules for inic devices 13/21813/1
authorScott Murray <scott.murray@konsulko.com>
Thu, 4 Jul 2019 13:05:11 +0000 (09:05 -0400)
committerScott Murray <scott.murray@konsulko.com>
Thu, 4 Jul 2019 13:05:11 +0000 (09:05 -0400)
Install a udev rules file in the unicens-config recipe to set the
group and SMACK label on the inic character devices so they are
accessible by services with the new audio permission.

Bug-AGL: SPEC-2591

Change-Id: I52135cf62ca8bfab0badd8850d49639d86ed73c1
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-config/unicens-config/files/55-inic.rules [new file with mode: 0644]
recipes-config/unicens-config/unicens-config.bb

diff --git a/recipes-config/unicens-config/files/55-inic.rules b/recipes-config/unicens-config/files/55-inic.rules
new file mode 100644 (file)
index 0000000..2da65cb
--- /dev/null
@@ -0,0 +1,4 @@
+# OS81118 devices for Microchip UNICENS
+KERNEL=="inic-usb-crx", SUBSYSTEM=="most_cdev_aim", GROUP="audio", SECLABEL{smack}="*"
+KERNEL=="inic-usb-ctx", SUBSYSTEM=="most_cdev_aim", GROUP="audio", SECLABEL{smack}="*"
+KERNEL=="inic-usb-itx1", SUBSYSTEM=="most_cdev_aim", GROUP="audio", SECLABEL{smack}="*"
index f33ffb2..4dd2074 100644 (file)
@@ -7,6 +7,7 @@ RDEPENDS_${PN} = "bash"
 SRC_URI = "\
     file://unicens-config.service \
     file://unicens-config.sh \
+    file://55-inic.rules \
 "
 
 
@@ -16,17 +17,15 @@ SYSTEMD_PACKAGES = "${PN}"
 SYSTEMD_SERVICE_${PN} = "unicens-config.service"
 SYSTEMD_AUTO_ENABLE_${PN} = "enable"
 
-do_configure () {
-}
-
-do_compile() {
-}
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
 
 do_install() {
     install -d ${D}${systemd_system_unitdir}
     install -m 0644 ${WORKDIR}/unicens-config.service ${D}${systemd_system_unitdir}
     install -d ${D}${bindir}
     install -m 0755 ${WORKDIR}/unicens-config.sh ${D}${bindir}
+    install -D -m 0644 ${WORKDIR}/55-inic.rules ${D}${sysconfdir}/udev/rules.d/55-inic.rules
 }
 
 FILES_${PN} += "${systemd_system_unitdir}"