Fix dependency issue with grpc in meta-agl-core 08/28508/3
authorJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 16 Feb 2023 11:37:24 +0000 (12:37 +0100)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 16 Feb 2023 16:56:28 +0000 (16:56 +0000)
grpc is not in the core layer but in meta-oe . Guard the dependency and only enable when
prerequisites are met like in here.

Bug-AGL: SPEC-4707
Change-Id: I9b28588562487681b227032967855f96dc0c9193
Signed-off-by: Jan-Simon Moeller <jsmoeller@linuxfoundation.org>
recipes-graphics/wayland/agl-compositor_%.bbappend [new file with mode: 0644]
recipes-graphics/wayland/agl-compositor_agldemo.inc [new file with mode: 0644]

diff --git a/recipes-graphics/wayland/agl-compositor_%.bbappend b/recipes-graphics/wayland/agl-compositor_%.bbappend
new file mode 100644 (file)
index 0000000..504e188
--- /dev/null
@@ -0,0 +1 @@
+require ${@bb.utils.contains('AGL_FEATURES', 'agldemo', 'agl-compositor_agldemo.inc', '', d)}
diff --git a/recipes-graphics/wayland/agl-compositor_agldemo.inc b/recipes-graphics/wayland/agl-compositor_agldemo.inc
new file mode 100644 (file)
index 0000000..5ea1a2d
--- /dev/null
@@ -0,0 +1,2 @@
+# enable grpc-proxy
+PACKAGECONFIG += "grpc-proxy"