Changes for building meta-agl-demo with YP 2.1.1 'krogoth' 37/6537/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 1 Sep 2016 21:25:44 +0000 (23:25 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Thu, 1 Sep 2016 21:26:16 +0000 (23:26 +0200)
    Update meta-agl-demo for YP 2.1 'krogoth'

    Notable changes:
    - update qtbase wrt packageconfig flags
    - qtwayland needs the patches checked/ported
    - remove qtwayland examples from packagegroup-agl-appfw-native

    TODO:
    - Check graphic driver stack (mesa, wayland, weston, qtbase, qtwayland et al.)
    - Check wrt SPEC-237
    - port patches for qtwayland
    - check where qtwayland-examples is gone and either remove or re-add

Change-Id: Ib14f1230d0fdc84f82af3e875460c0269faec652
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-qt/packagegroups/packagegroup-agl-appfw-native-qt5.bb
recipes-qt/qt5/qtbase_%.bbappend
recipes-qt/qt5/qtwayland_%.bbappend

index abc62d8..1fe2579 100644 (file)
@@ -31,12 +31,15 @@ RDEPENDS_${PN} += "\
     qtquick1-plugins \
     qtquick1-tools \
     qtwayland \
-    qtwayland-examples \
     qtwayland-plugins \
     qtwayland-tools \
     qtgraphicaleffects-qmlplugins \
     qml-execscript-plugin \
     "
+RDEPENDS_${PN}_checkforkrogoth += "\
+    qtwayland-examples \
+    "
+
 
 # qtwebkit
 # qtwebkit-qmlplugins
index ebca5c8..026e76f 100644 (file)
@@ -1,13 +1,13 @@
 FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
 
-SRC_URI_append = "\
-    file://0001-Force-qdbus-to-make-introspect-for-every-findMetaObj.patch \
-    "
-
 DEPENDS_append_koelsch = " libegl"
 DEPENDS_append_porter = " libegl"
 
 PACKAGECONFIG_GL = "${@bb.utils.contains('DISTRO_FEATURES', 'opengl', 'gles2', '', d)}"
-PACKAGECONFIG_append = " icu accessibility"
+PACKAGECONFIG_append = " icu accessibility eglfs"
+PACKAGECONFIG_append_rpi = " fontconfig"
+
+EXTRA_OECONF_append = ""
+
 
-EXTRA_OECONF_append = " -qpa wayland"
+PACKAGECONFIG[gles2]="-opengl es2 -eglfs,,virtual/libgles2 virtual/egl"
index b61b121..ed9e374 100644 (file)
@@ -22,10 +22,13 @@ FILESEXTRAPATHS_append := ":${THISDIR}/${PN}"
 
 SRC_URI_append = "\
     file://0010-Added-manifest-file-according-to-smack-3-domain-mode.patch \
+    "
+SRC_URI_append_checkforkrogoth = "\
     file://disable_xcomposite_egl_qt_wayland_client_buffer_integration.patch \
     file://0001-Implement-initial-IVI-shell-support-with-shell-integ.patch \
     file://0002-Fix-multiple-QWindow.patch \
     "
 
+
 DEPENDS_append_koelsch = " libegl gles-user-module"
 DEPENDS_append_porter = " libegl gles-user-module"