agl-service-radio: add recipe for newly standalone binding 57/10657/4
authorMatt Ranostay <matt.ranostay@konsulko.com>
Fri, 18 Aug 2017 00:50:45 +0000 (03:50 +0300)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 4 Sep 2017 22:16:15 +0000 (22:16 +0000)
Now that the radio binding is standalone their needs to be a
recipe to build it, and a RDEPENDS added to the radio application.

Bug-AGL: SPEC-834
Change-Id: I1d830181c6dcd12036b8e39d0442e010d579194e
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb [new file with mode: 0644]
recipes-demo-hmi/radio/radio_git.bb

diff --git a/recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb b/recipes-demo-hmi/agl-service-radio/agl-service-radio_git.bb
new file mode 100644 (file)
index 0000000..bab9f13
--- /dev/null
@@ -0,0 +1,20 @@
+SUMMARY     = "Radio Service Binding"
+DESCRIPTION = "AGL Radio Service Binding"
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/agl-service-radio"
+SECTION     = "apps"
+
+
+LICENSE     = "Apache-2.0 & GPLv2+"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984 \
+                    file://COPYING;md5=751419260aa954499f7abaabaa882bbe"
+
+SRC_URI = "gitsm://gerrit.automotivelinux.org/gerrit/apps/agl-service-radio;protocol=http"
+SRCREV  = "${AUTOREV}"
+
+PV = "1.0+git${SRCPV}"
+S  = "${WORKDIR}/git"
+
+# build-time dependencies
+DEPENDS = "rtl-sdr glib-2.0 pulseaudio alsa-lib"
+
+inherit cmake aglwgt pkgconfig
index ca75f2d..41e78d3 100644 (file)
@@ -18,7 +18,7 @@ PV = "1.0+git${SRCPV}"
 S  = "${WORKDIR}/git"
 
 # build-time dependencies
-DEPENDS = "qtquickcontrols2 rtl-sdr glib-2.0 pulseaudio alsa-lib"
+DEPENDS = "qtquickcontrols2"
 
 inherit qmake5 aglwgt
 
@@ -37,3 +37,5 @@ FILES_${PN} += " \
        /home/root/app-data/radio/presets-*.conf \
        /home/root/app-data/radio/presets.conf \
 "
+
+RDEPENDS_${PN} += "agl-service-radio"