Add agl-cluster-demo-support feature 19/18619/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 3 Dec 2018 19:29:19 +0000 (14:29 -0500)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 10 Dec 2018 13:55:45 +0000 (13:55 +0000)
Add new feature to enable support for the cluster demo.  At the moment,
it pulls in the agl-gstrecorder feature and enables building the required
mapviewer application.

Bug-AGL: SPEC-1730

Change-Id: I18c0312eefca9bb8c591e8b8a2b8113b4e94c7fc
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
(cherry picked from commit af3ecc175fdb3cfbb7501ec5f1aad7718c08472a)

recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
templates/feature/agl-cluster-demo-support/50_local.conf.inc [new file with mode: 0644]
templates/feature/agl-cluster-demo-support/included.dep [new file with mode: 0644]

index f3191ca..9deaea2 100755 (executable)
@@ -37,9 +37,6 @@ MOST_HVAC_append = " \
 MOST_HVAC_dra7xx-evm = ""
 MOST_HVAC_dragonboard-410c = ""
 
-# mapviewer and mapviewer-demo requires AGL CES2017 demo mock-up
-MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-mapviewer-demo", " mapviewer mapviewer-demo", "",d)}"
-
 AGL_APPS = " \
     dashboard \
     hvac \
@@ -61,15 +58,18 @@ AGL_APIS = " \
 
 QTAGLEXTRAS = "${@bb.utils.contains("DISTRO_FEATURES", "agl-hmi-framework", " qtaglextras", "",d)}"
 
+# mapviewer and mapviewer-demo are required for AGL cluster demo
+MAPVIEWER = "${@bb.utils.contains("DISTRO_FEATURES", "agl-cluster-demo-support", " mapviewer mapviewer-demo", "",d)}"
+
 RDEPENDS_${PN}_append = " \
     qtquickcontrols2-agl \
     qtquickcontrols2-agl-style \
     linux-firmware-ralink \
-    ${QTAGLEXTRAS} \
-    ${MAPVIEWER} \
     ${MOST_HVAC} \
     ${AGL_APPS} \
     ${AGL_APIS} \
+    ${QTAGLEXTRAS} \
+    ${MAPVIEWER} \
     "
 
 
diff --git a/templates/feature/agl-cluster-demo-support/50_local.conf.inc b/templates/feature/agl-cluster-demo-support/50_local.conf.inc
new file mode 100644 (file)
index 0000000..f4724b5
--- /dev/null
@@ -0,0 +1 @@
+DISTRO_FEATURES_append = " agl-cluster-demo-support"
diff --git a/templates/feature/agl-cluster-demo-support/included.dep b/templates/feature/agl-cluster-demo-support/included.dep
new file mode 100644 (file)
index 0000000..17ef3ba
--- /dev/null
@@ -0,0 +1 @@
+agl-gstrecorder