Merge branch 'next' 33/24433/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 27 Apr 2020 15:35:50 +0000 (17:35 +0200)
committerJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 27 Apr 2020 15:35:59 +0000 (17:35 +0200)
* next:
  Remove vboxguestdrivers recipe
  packagegroup-agl-demo: remove python-curses
  agl-demo-platform-crosssdk: remove Chromium specific bits from SDK
  Remove ttf-noto-emoji recipe
  Declare layer compatibility for dunfell

Change-Id: I2393ea0057dfac4abecf1c965ca337c26a5532be
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
conf/layer.conf
recipes-devtools/gn/gn.inc [deleted file]
recipes-devtools/gn/gn_66.0.3340.0.r534306.bb [deleted file]
recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bb [deleted file]
recipes-platform/images/agl-demo-platform-crosssdk.bb
recipes-platform/packagegroups/packagegroup-agl-demo.bb
recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils [deleted file]
recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.2.bb [deleted file]

index d62e61b..7da7ac0 100644 (file)
@@ -9,4 +9,4 @@ BBFILE_COLLECTIONS += "agl-demo"
 BBFILE_PATTERN_agl-demo = "^${LAYERDIR}/"
 BBFILE_PRIORITY_agl-demo = "7"
 
-LAYERSERIES_COMPAT_agl-demo = "zeus"
+LAYERSERIES_COMPAT_agl-demo = "dunfell"
diff --git a/recipes-devtools/gn/gn.inc b/recipes-devtools/gn/gn.inc
deleted file mode 100644 (file)
index 2728bc1..0000000
+++ /dev/null
@@ -1,21 +0,0 @@
-SUMMARY = "Meta-build system from Google"
-LICENSE = "BSD"
-LIC_FILES_CHKSUM = "file://LICENSE;md5=0fca02217a5d49a14dfe2d11837bb34d"
-
-DEPENDS = "python-native ninja-native"
-
-SRC_URI = "http://gsdview.appspot.com/chromium-browser-official/chromium-${PV}.tar.xz"
-
-S ?= "${WORKDIR}/chromium-${PV}"
-
-do_compile () {
-  cd ${S}/tools/gn
-  ./bootstrap/bootstrap.py -s
-}
-
-do_install () {
-  install -d ${D}${bindir}
-  install -m 0755 out/Release/gn ${D}${bindir}/gn
-}
-
-BBCLASSEXTEND = "native nativesdk"
diff --git a/recipes-devtools/gn/gn_66.0.3340.0.r534306.bb b/recipes-devtools/gn/gn_66.0.3340.0.r534306.bb
deleted file mode 100644 (file)
index d3959f2..0000000
+++ /dev/null
@@ -1,8 +0,0 @@
-require gn.inc
-
-S = "${WORKDIR}/chromium-ozone-wayland-dev-${PV}.igalia.1"
-
-SRC_URI = "https://tmp.igalia.com/chromium-tarballs/chromium-ozone-wayland-dev-${PV}.igalia.1.tar.xz"
-
-SRC_URI[md5sum] = "f418f4df5261cfdcf39e7901924876a2"
-SRC_URI[sha256sum] = "2679c89f09394bf2df86a090958a599303562746ce9296b07c263eb16f8d9148"
diff --git a/recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bb b/recipes-graphics/ttf-fonts/ttf-noto-emoji_20190815.bb
deleted file mode 100644 (file)
index 38aaa4e..0000000
+++ /dev/null
@@ -1,19 +0,0 @@
-require ../../../external/meta-openembedded/meta-oe/recipes-graphics/ttf-fonts/ttf.inc
-
-SUMMARY = "Google noto emoji font pack"
-HOMEPAGE = "https://github.com/googlefonts/noto-emoji"
-LICENSE = "OFL-1.1"
-LIC_FILES_CHKSUM = "file://fonts/LICENSE;md5=55719faa0112708e946b820b24b14097"
-
-SRC_URI = "git://github.com/googlefonts/noto-emoji;protocol=https"
-SRCREV = "833a43d03246a9325e748a2d783006454d76ff66"
-
-PACKAGES = "${PN}-color ${PN}-regular"
-FONT_PACKAGES = "${PN}-color ${PN}-regular"
-
-S = "${WORKDIR}/git"
-
-FILES_${PN}-color = "${datadir}/fonts/truetype/NotoColorEmoji.ttf"
-FILES_${PN}-regular = "${datadir}/fonts/truetype/NotoEmoji-Regular.ttf"
-
-do_compile[noexec] = "1"
index a814b69..5bb0dc0 100755 (executable)
@@ -18,37 +18,6 @@ inherit populate_sdk populate_sdk_qt5
 # can failed (randomly).
 addtask do_populate_sdk after do_rootfs
 
-# native tools to support Chromium build inside SDK (SPEC-942)
-TOOLCHAIN_HOST_TASK += " \
-    nativesdk-gn \
-    nativesdk-ninja \
-    nativesdk-gperf \
-    nativesdk-zlib \
-    nativesdk-xz \
-    nativesdk-nspr-dev \
-    nativesdk-nss-dev \
-    nativesdk-lua \
-    "
-
-# required dependencies for Chromium build inside SDK (SPEC-942)
-TOOLCHAIN_TARGET_TASK += " \
-    pciutils-dev \
-    ${@bb.utils.contains('DISTRO_FEATURES', 'pulseaudio', 'pulseaudio-dev' , '', d)} \
-    cairo-dev \
-    nss-dev \
-    cups-dev \
-    gconf-dev \
-    libexif-dev \
-    pango-dev \
-    libdrm-dev  \
-    lua-dev \
-    lua-staticdev \
-    libafb-helpers-staticdev \
-    libafb-helpers-qt-staticdev \
-    libappcontroller-staticdev \
-    ${@bb.utils.contains('LICENSE_FLAGS_WHITELIST', 'commercial', 'ffmpeg-dev', '', d)} \
-    "
-
 # Add wayland-scanner to SDK (SPEC-945)
 # Use TOOLCHAIN_HOST_TASK instead of adding to the packagegroup
 # wayland-scanner is in nativesdk-wayland-dev !
index 86da340..5f82f09 100644 (file)
@@ -72,7 +72,6 @@ RDEPENDS_${PN} += " \
     linux-firmware-ralink \
     can-utils \
     iproute2 \
-    python-curses \
     dhcp-client \
     ${UNICENS} \
     ${MOST_DRIVERS} \
diff --git a/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils b/recipes-support/vboxguestdrivers/vboxguestdrivers/Makefile.utils
deleted file mode 100644 (file)
index 495601f..0000000
+++ /dev/null
@@ -1,45 +0,0 @@
-## -----------------------------------------------------------------------
-##
-##   Copyright 2001-2008 H. Peter Anvin - All Rights Reserved
-##
-##   This program is free software; you can redistribute it and/or modify
-##   it under the terms of the GNU General Public License as published by
-##   the Free Software Foundation, Inc., 53 Temple Place Ste 330,
-##   Boston MA 02111-1307, USA; either version 2 of the License, or
-##   (at your option) any later version; incorporated herein by reference.
-##
-## -----------------------------------------------------------------------
-
-INCLUDES = -I. -I../vboxsf -I../vboxsf/include
-MOD_DEFS = -DRT_OS_LINUX -DIN_RING0 -DIN_RT_R0 \
-           -DIN_SUP_R0 -DVBOX -DVBOX_WITH_HGCM -DIN_MODULE -DIN_GUEST_R0
-CFLAGS  = ${INCLUDES} ${MOD_DEFS}
-LDFLAGS         =
-
-SRCS     = mount.vboxsf.c \
-           vbsfmount.c
-
-OBJS    = $(patsubst %.c,%.o,$(notdir $(SRCS)))
-
-.SUFFIXES: .c .o .i .s .S
-
-
-all: mount.vboxsf
-
-clean:
-       -rm -f *.o mount.vboxsf
-
-spotless: clean
-       -rm -f *~
-
-mount.vboxsf: $(OBJS)
-       $(CC) $(LDFLAGS) -o $@ $^
-
-%.o: %.c
-       $(CC) $(UMAKEDEPS) $(CFLAGS) -c -o $@ $<
-%.i: %.c
-       $(CC) $(UMAKEDEPS) $(CFLAGS) -E -o $@ $<
-%.s: %.c
-       $(CC) $(UMAKEDEPS) $(CFLAGS) -S -o $@ $<
-
--include .*.d *.tmp
diff --git a/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.2.bb b/recipes-support/vboxguestdrivers/vboxguestdrivers_6.1.2.bb
deleted file mode 100644 (file)
index 62c2b50..0000000
+++ /dev/null
@@ -1,81 +0,0 @@
-SUMMARY = "VirtualBox Linux Guest Drivers"
-SECTION = "core"
-LICENSE = "GPL-2.0"
-LIC_FILES_CHKSUM = "file://${WORKDIR}/${VBOX_NAME}/COPYING;md5=e197d5641bb35b29d46ca8c4bf7f2660"
-
-DEPENDS = "virtual/kernel"
-
-inherit module kernel-module-split
-
-COMPATIBLE_MACHINE = "(qemux86|qemux86-64)"
-
-VBOX_NAME = "VirtualBox-${PV}"
-
-SRC_URI = "http://download.virtualbox.org/virtualbox/${PV}/${VBOX_NAME}.tar.bz2 \
-    file://Makefile.utils \
-"
-SRC_URI[md5sum] = "f4f42fd09857556b04b803fb99cc6905"
-SRC_URI[sha256sum] = "4326576e8428ea3626194fc82646347576e94c61f11d412a669fc8a10c2a1e67"
-
-S = "${WORKDIR}/vbox_module"
-
-export BUILD_TARGET_ARCH="${ARCH}"
-export BUILD_TARGET_ARCH_x86-64="amd64"
-
-EXTRA_OEMAKE += "KERN_DIR='${WORKDIR}/${KERNEL_VERSION}/build' KBUILD_VERBOSE=1"
-
-# otherwise 5.2.22 builds just vboxguest
-MAKE_TARGETS = "all"
-
-addtask export_sources after do_patch before do_configure
-
-do_export_sources() {
-    mkdir -p "${S}"
-    ${WORKDIR}/${VBOX_NAME}/src/VBox/Additions/linux/export_modules.sh ${T}/vbox_modules.tar.gz
-    tar -C "${S}" -xzf ${T}/vbox_modules.tar.gz
-
-    # add a mount utility to use shared folder from VBox Addition Source Code
-    mkdir -p "${S}/utils"
-    install ${WORKDIR}/${VBOX_NAME}/src/VBox/Additions/linux/sharedfolders/mount.vboxsf.c ${S}/utils
-    install ${WORKDIR}/${VBOX_NAME}/src/VBox/Additions/linux/sharedfolders/vbsfmount.c ${S}/utils
-    install ${S}/../Makefile.utils ${S}/utils/Makefile
-
-}
-
-do_configure_prepend() {
-    # vboxguestdrivers/5.2.6-r0/vbox_module/vboxguest/Makefile.include.header:99: *** The variable KERN_DIR must be a kernel build folder and end with /build without a trailing slash, or KERN_VER must be set.  Stop.
-    # vboxguestdrivers/5.2.6-r0/vbox_module/vboxguest/Makefile.include.header:108: *** The kernel build folder path must end in <version>/build, or the variable KERN_VER must be set.  Stop.
-    mkdir -p ${WORKDIR}/${KERNEL_VERSION}
-    ln -snf ${STAGING_KERNEL_DIR} ${WORKDIR}/${KERNEL_VERSION}/build
-}
-
-# compile and install mount utility
-do_compile() {
-    oe_runmake all
-    oe_runmake 'LD=${CC}' 'LDFLAGS=${LDFLAGS}' -C ${S}/utils
-    if ! [ -e vboxguest.ko -a -e vboxsf.ko -a -e vboxvideo.ko ] ; then
-        echo "ERROR: One of vbox*.ko modules wasn't built"
-        exit 1
-    fi
-}
-
-module_do_install() {
-    MODULE_DIR=${D}${nonarch_base_libdir}/modules/${KERNEL_VERSION}/kernel/misc
-    install -d $MODULE_DIR
-    install -m 644 vboxguest.ko $MODULE_DIR
-    install -m 644 vboxsf.ko $MODULE_DIR
-    install -m 644 vboxvideo.ko $MODULE_DIR
-}
-
-do_install_append() {
-    install -d ${D}${base_sbindir}
-    install -m 755 ${S}/utils/mount.vboxsf ${D}${base_sbindir}
-}
-
-PACKAGES += "kernel-module-vboxguest kernel-module-vboxsf kernel-module-vboxvideo"
-RRECOMMENDS_${PN} += "kernel-module-vboxguest kernel-module-vboxsf kernel-module-vboxvideo"
-
-FILES_${PN} = "${base_sbindir}"
-
-# autoload if installed
-KERNEL_MODULE_AUTOLOAD += "vboxguest vboxsf vboxvideo"