Add lin-config tool to facilitate polling 57/22857/1
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Mon, 21 Oct 2019 09:33:54 +0000 (11:33 +0200)
committerScott Murray <scott.murray@konsulko.com>
Tue, 5 Nov 2019 00:36:01 +0000 (00:36 +0000)
This tool allows to setup the BCM in the linux kernel to poll the lin bus.
This is needed to query the steering wheel.

Bug-AGL: SPEC-2918

.

Change-Id: I4887c0d179b4e93aa7bae6406057a8bd8ba79999
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
(cherry picked from commit 8a55ca4d1658c18f8b750c0a2d9e07a65099e31d)

recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch [new file with mode: 0644]
recipes-support/lin-config/lin-config_git.bb [new file with mode: 0644]

diff --git a/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch b/recipes-support/lin-config/files/0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch
new file mode 100644 (file)
index 0000000..fe08b7d
--- /dev/null
@@ -0,0 +1,33 @@
+From 59acd73ba3bd6cc4151b890d135c6d690a83374d Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Jan-Simon=20M=C3=B6ller?= <jsmoeller@linuxfoundation.org>
+Date: Tue, 1 Oct 2019 15:24:07 +0000
+Subject: [PATCH] Change Makefile to use pkg-config for libxml-2.0
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+instead of xml2-config.
+
+Upstream-Status: Pending
+
+Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
+---
+ lin_config/src/Makefile | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+diff --git a/Makefile b/Makefile
+index cf5c515..3fc4df1 100644
+--- a/Makefile
++++ b/Makefile
+@@ -1,6 +1,5 @@
+-CC=gcc
+-CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `xml2-config --cflags` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
+-LIBS=`xml2-config --libs` `pkg-config --libs libnl-route-3.0`
++CFLAGS=-std=gnu99 -Wall -pedantic $(DEBUG) `pkg-config --cflags libxml-2.0` `pkg-config --cflags libnl-route-3.0` -I$(INCLUDE)
++LIBS=`pkg-config --libs libxml-2.0` `pkg-config --libs libnl-route-3.0`
+ INCLUDE=../../sllin
+ DEBUG=-ggdb
+-- 
+2.16.4
+
diff --git a/recipes-support/lin-config/lin-config_git.bb b/recipes-support/lin-config/lin-config_git.bb
new file mode 100644 (file)
index 0000000..6c8db84
--- /dev/null
@@ -0,0 +1,27 @@
+DESCRIPTION = "lin-config tool for the sllin driver module"
+LICENSE = "GPLv2"
+LIC_FILES_CHKSUM = "file://${COMMON_LICENSE_DIR}/GPL-2.0;md5=801f80980d171dd6425610833a22dbe6"
+
+
+DEPENDS += "libnl libxml2"
+
+SRC_URI = "git://github.com/trainman419/linux-lin.git;protocol=https"
+SRCREV = "155d885e8ccc907a56f6c86c4b159fac27ef6fec"
+S = "${WORKDIR}/git/lin_config/src"
+
+SRC_URI_append = " \
+       file://0001-Change-Makefile-to-use-pkg-config-for-libxml-2.0.patch \
+       "
+
+inherit pkgconfig
+
+PV = "0.1+git${SRCPV}"
+
+
+do_configure[noexec] = "1"
+
+do_install_append() {
+
+    install -d ${D}/${bindir}
+    install -m 644 ${S}/lin_config ${D}/${bindir}
+}
\ No newline at end of file