graphics: add noto-emoji git recipe 32/22232/2
authorMatt Ranostay <matt.ranostay@konsulko.com>
Tue, 20 Aug 2019 00:33:02 +0000 (03:33 +0300)
committerMatt Ranostay <matt.ranostay@konsulko.com>
Wed, 28 Aug 2019 23:39:52 +0000 (02:39 +0300)
Add color emoji support to AGL via the noto-emoji font.

Bug-AGL: SPEC-2701
Change-Id: Idf21d5c3f8ac2fe0fe25945b6dca1d8956fb7f7b
Signed-off-by: Matt Ranostay <matt.ranostay@konsulko.com>
recipes-graphics/noto-emoji/noto-emoji_git.bb [new file with mode: 0644]

diff --git a/recipes-graphics/noto-emoji/noto-emoji_git.bb b/recipes-graphics/noto-emoji/noto-emoji_git.bb
new file mode 100644 (file)
index 0000000..416f568
--- /dev/null
@@ -0,0 +1,25 @@
+SUMMARY     = "Google noto emoji font pack"
+HOMEPAGE    = "https://github.com/googlefonts/noto-emoji"
+SECTION     = "fonts"
+
+LICENSE     = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "git://github.com/googlefonts/noto-emoji;protocol=https;branch=master"
+SRCREV = "833a43d03246a9325e748a2d783006454d76ff66"
+
+RDEPENDS_${PN} = "fontconfig"
+
+S = "${WORKDIR}/git"
+
+do_install() {
+    install -m 0755 -d ${D}/${datadir}/fonts/ttf
+    install -m 0644 -p ${S}/NotoColorEmoji.ttf ${D}/${datadir}/fonts/ttf
+}
+
+FILES_${PN} += "${datadir}/fonts/ttf/NotoColorEmoji.ttf"
+
+inherit allarch fontcache
+
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"