ondemandnavi: use OSM tiles by default 59/22459/2
authorJan-Simon Möller <jsmoeller@linuxfoundation.org>
Fri, 20 Sep 2019 09:12:53 +0000 (11:12 +0200)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Fri, 20 Sep 2019 17:27:49 +0000 (17:27 +0000)
To simplify development switch to use the OSM tiles
as it requires no API key.

Bug-AGL: SPEC-2821

Change-Id: I28fd97a7ce8443547ebb4ac6f1006780e3620d28
Signed-off-by: Jan-Simon Möller <jsmoeller@linuxfoundation.org>
recipes-demo-hmi/navigation/ondemandnavi_git.bb

index 03c3cdb..e15429b 100644 (file)
@@ -22,6 +22,10 @@ SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
 
 S = "${WORKDIR}/git"
 
+# Use OSM tiles by default.
+# For mapbox tiles, just comment this out and set an api key.
+EXTRA_QMAKEVARS_CONFIGURE += "ENABLE_OSM=1"
+
 inherit qmake5 aglwgt pkgconfig
 
 do_install_append() {
 inherit qmake5 aglwgt pkgconfig
 
 do_install_append() {