Rename agl-cluster-demo-support feature 11/27711/1
authorScott Murray <scott.murray@konsulko.com>
Mon, 6 Jun 2022 21:49:59 +0000 (17:49 -0400)
committerScott Murray <scott.murray@konsulko.com>
Wed, 6 Jul 2022 18:00:05 +0000 (14:00 -0400)
Rename agl-cluster-demo-support feature to agl-demo-cluster-support
to make it clearer that it relates to the agl-demo-platform image.

Bug-AGL: SPEC-4425

Signed-off-by: Scott Murray <scott.murray@konsulko.com>
Change-Id: I9e1ebd2800ab55f3969be98034b60fcb4c09ba21

recipes-connectivity/connman/connman-conf_agldemo.inc
recipes-platform/packagegroups/packagegroup-agl-demo-platform.bb
templates/feature/agl-cluster-demo-support/50_local.conf.inc [deleted file]
templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md [deleted file]
templates/feature/agl-demo-cluster-support/50_local.conf.inc [new file with mode: 0644]
templates/feature/agl-demo-cluster-support/README_feature_agl-demo-cluster-support.md [new file with mode: 0644]
templates/feature/agl-demo-cluster-support/included.dep [moved from templates/feature/agl-cluster-demo-support/included.dep with 100% similarity]

index 5b732ae..7b736ec 100644 (file)
@@ -1,6 +1,6 @@
 do_install:append() {
     # Need to ignore eth1 in cluster demo setup
-    if ${@bb.utils.contains('AGL_FEATURES', 'agl-cluster-demo-support', 'true', 'false', d)}; then
+    if ${@bb.utils.contains('AGL_FEATURES', 'agl-demo-cluster-support', 'true', 'false', d)}; then
         sed -i 's/^\(NetworkInterfaceBlacklist=.*\)/\1,eth1/' ${D}${sysconfdir}/connman/main.conf
     fi
 }
index 9c4553f..fdebd24 100644 (file)
@@ -39,7 +39,7 @@ CLUSTER_SUPPORT_PACKAGES = " \
        tbtnavi \
        cluster-demo-network-config \
 "
-CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-cluster-demo-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
+CLUSTER_SUPPORT = "${@bb.utils.contains("AGL_FEATURES", "agl-demo-cluster-support", "${CLUSTER_SUPPORT_PACKAGES}", "",d)}"
 
 # Hook for demo platform configuration
 # ATM used for:
diff --git a/templates/feature/agl-cluster-demo-support/50_local.conf.inc b/templates/feature/agl-cluster-demo-support/50_local.conf.inc
deleted file mode 100644 (file)
index 0be5431..0000000
+++ /dev/null
@@ -1 +0,0 @@
-AGL_FEATURES:append = " agl-cluster-demo-support"
diff --git a/templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md b/templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md
deleted file mode 100644 (file)
index bdb04f0..0000000
+++ /dev/null
@@ -1,15 +0,0 @@
----
-description: Feature agl-cluster-demo-support
-authors: Scott Murray <scott.murray@konsulko.com>
----
-       
-### Feature agl-cluster-demo-support
-        
-*Description is missing - please complete file meta-agl-demo/templates/feature/agl-cluster-demo-support/README_feature_agl-cluster-demo-support.md*
-
-#### Dependent features pulled by agl-cluster-demo-support
-
-The following features are pulled:
-
-* agl-gstrecorder
-
diff --git a/templates/feature/agl-demo-cluster-support/50_local.conf.inc b/templates/feature/agl-demo-cluster-support/50_local.conf.inc
new file mode 100644 (file)
index 0000000..188d8e8
--- /dev/null
@@ -0,0 +1 @@
+AGL_FEATURES:append = " agl-demo-cluster-support"
diff --git a/templates/feature/agl-demo-cluster-support/README_feature_agl-demo-cluster-support.md b/templates/feature/agl-demo-cluster-support/README_feature_agl-demo-cluster-support.md
new file mode 100644 (file)
index 0000000..a9ff2cf
--- /dev/null
@@ -0,0 +1,17 @@
+---
+description: Feature agl-demo-cluster-support
+authors: Scott Murray <scott.murray@konsulko.com>
+---
+       
+### Feature agl-demo-cluster-support
+        
+Enables support for remote navigation display on a connected board running
+the agl-cluster-demo-platform image.  The configuration is in large part
+intended for use with the AGL tradeshow demo setup.
+
+#### Dependent features pulled by agl-demo-cluster-support
+
+The following features are pulled:
+
+* agl-weston-remoting
+