Fixed WindowManager startup 77/8677/2
authorRonan Le Martret <ronan.lemartret@iot.bzh>
Wed, 8 Mar 2017 10:42:50 +0000 (11:42 +0100)
committerRonan Le Martret <ronan.lemartret@iot.bzh>
Thu, 9 Mar 2017 14:38:12 +0000 (15:38 +0100)
 * WindowManager must start only when
   weston is ready.

 [SPEC-470]

Change-Id: I1d63cdb60223686e18ed49fa48d2a14bb978949b
Signed-off-by: Ronan Le Martret <ronan.lemartret@iot.bzh>
recipes-demo-hmi/windowmanager/windowmanager_git.bb

index 013f445..f6119aa 100644 (file)
@@ -26,9 +26,10 @@ do_install() {
     
     install -d ${D}${systemd_user_unitdir}
     install -m 0644 ${S}/windowmanager/conf/WindowManager.service ${D}${systemd_user_unitdir}
+    install -m 0644 ${S}/windowmanager/conf/WindowManager.path ${D}${systemd_user_unitdir}
 
     install -d ${D}${sysconfdir}/systemd/user/default.target.wants
-    ln -sf ${systemd_user_unitdir}/WindowManager.service ${D}${sysconfdir}/systemd/user/default.target.wants
+    ln -sf ${systemd_user_unitdir}/WindowManager.path ${D}${sysconfdir}/systemd/user/default.target.wants
 }
 
 FILES_${PN} += "/usr/AGL/${PN}/ ${systemd_user_unitdir}"