html5-hvac_git: Remove autobuild script builds 80/27280/2
authorduerpei <duep.fnst@fujitsu.com>
Thu, 24 Mar 2022 06:48:14 +0000 (14:48 +0800)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Thu, 24 Mar 2022 20:53:06 +0000 (20:53 +0000)
Bug-AGL: SPEC-4309

Signed-off-by: duerpei <duep.fnst@fujitsu.com>
Change-Id: Idef28f993af074f7e43b6475b4b53576572f7d9e
(cherry picked from commit bbdac38957c239b73bcbf409be2efceef3e5d6f5)

recipes-demo/html5-hvac/html5-hvac_git.bb

index 85fed29..16bf739 100644 (file)
@@ -17,9 +17,10 @@ SRCREV = "${AGL_APP_REVISION}"
 DEPENDS = "nodejs-native"
 
 do_compile() {
-  bldcmd=${S}/autobuild/agl/autobuild
   cd ${S}
-  $bldcmd build
+  rm -rf package node_modules package-lock.json
+  npm install
+  npm run build
 }
 
 WAM_APPLICATIONS_DIR="${libdir}/wam_apps"
@@ -35,4 +36,4 @@ do_install() {
 FILES_${PN} = " \
   ${WAM_APPLICATIONS_DIR}/${PN} \
   ${APPLICATIONS_DIR} \
-"
\ No newline at end of file
+"