Replace "/etc" with "${sysconfidir}" 80/27480/2
authorduerpei <duep.fnst@fujitsu.com>
Fri, 13 May 2022 06:32:49 +0000 (14:32 +0800)
committerJan-Simon Moeller <jsmoeller@linuxfoundation.org>
Mon, 16 May 2022 12:11:21 +0000 (12:11 +0000)
make them more standardized

Bug-AGL: SPEC-4374

Signed-off-by: duerpei <duep.fnst@fujitsu.com>
Change-Id: I869eeef40a539b7fc085ac1cb969e8c4699f131f

recipes-core/dbus/dbus_agldemo.inc
recipes-graphics/kms-conf/kms-conf_1.0.bb

index a642d3e..193db5d 100644 (file)
@@ -16,8 +16,8 @@ do_install:append() {
 
             # Execute these manually on behalf of systemctl script (from systemd-systemctl-native.bb)
             # because it does not support systemd's user mode.
-            mkdir -p ${D}/etc/systemd/user/default.target.wants/
-            ln -sf ${systemd_user_unitdir}/dbus.socket ${D}/etc/systemd/user/default.target.wants/dbus.socket
+            mkdir -p ${D}${sysconfdir}/systemd/user/default.target.wants/
+            ln -sf ${systemd_user_unitdir}/dbus.socket ${D}${sysconfdir}/systemd/user/default.target.wants/dbus.socket
         fi
     fi
 }
index c2ac9c5..4a665a4 100644 (file)
@@ -7,6 +7,6 @@ SRC_URI = " \
 "
 
 do_install:append() {
-    install -d ${D}/etc
-    install -m 644 ${WORKDIR}/kms.conf ${D}/etc
+    install -d ${D}${sysconfdir}
+    install -m 644 ${WORKDIR}/kms.conf ${D}${sysconfdir}
 }