flutter-homescreen: add recipe 47/28147/2
authorScott Murray <scott.murray@konsulko.com>
Mon, 21 Nov 2022 07:50:37 +0000 (02:50 -0500)
committerScott Murray <scott.murray@konsulko.com>
Mon, 21 Nov 2022 16:29:32 +0000 (11:29 -0500)
Add recipe for Flutter homescreen application.

Bug-AGL: SPEC-4615

Change-Id: I71510ff462c84bed0de36e889455828a4feb02b3
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo/flutter-homescreen/files/flutter-homescreen-debug.json [new file with mode: 0644]
recipes-demo/flutter-homescreen/files/flutter-homescreen-profile.json [new file with mode: 0644]
recipes-demo/flutter-homescreen/files/flutter-homescreen-release.json [new file with mode: 0644]
recipes-demo/flutter-homescreen/files/flutter-homescreen.service [new file with mode: 0644]
recipes-demo/flutter-homescreen/flutter-homescreen_git.bb [new file with mode: 0644]

diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen-debug.json b/recipes-demo/flutter-homescreen/files/flutter-homescreen-debug.json
new file mode 100644 (file)
index 0000000..7741e3a
--- /dev/null
@@ -0,0 +1,11 @@
+{
+        "view" : [ {
+                "window_type" : "BG",
+                "bundle_path" : "/usr/share/flutter/flutter_homescreen",
+                "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234"],
+                "width" : 1920,
+                "height": 1080,
+                "fullscreen": true
+                }
+        ]
+}
diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen-profile.json b/recipes-demo/flutter-homescreen/files/flutter-homescreen-profile.json
new file mode 100644 (file)
index 0000000..128800e
--- /dev/null
@@ -0,0 +1,11 @@
+{
+        "view" : [ {
+                "window_type" : "BG",
+                "bundle_path" : "/usr/share/flutter/flutter_homescreen",
+                "vm_args":["--observatory-host", "0.0.0.0", "--observatory-port", "1234", "--start-paused"],
+                "width" : 1920,
+                "height": 1080,
+                "fullscreen": true
+                }
+        ]
+}
diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen-release.json b/recipes-demo/flutter-homescreen/files/flutter-homescreen-release.json
new file mode 100644 (file)
index 0000000..544a8e5
--- /dev/null
@@ -0,0 +1,10 @@
+{
+        "view" : [ {
+                "window_type" : "BG",
+                "bundle_path" : "/usr/share/flutter/flutter_homescreen",
+                "width" : 1920,
+                "height": 1080,
+                "fullscreen": true
+                }
+        ]
+}
diff --git a/recipes-demo/flutter-homescreen/files/flutter-homescreen.service b/recipes-demo/flutter-homescreen/files/flutter-homescreen.service
new file mode 100644 (file)
index 0000000..300fb22
--- /dev/null
@@ -0,0 +1,10 @@
+[Unit]
+Requires=agl-compositor.service
+After=agl-compositor.service
+
+[Service]
+ExecStart=/usr/bin/flutter-auto --j=/usr/share/flutter/flutter-homescreen.json --xdg-shell-app-id=homescreen
+Restart=on-failure
+
+[Install]
+WantedBy=agl-session.target
diff --git a/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb b/recipes-demo/flutter-homescreen/flutter-homescreen_git.bb
new file mode 100644 (file)
index 0000000..1f6f018
--- /dev/null
@@ -0,0 +1,38 @@
+SUMMARY = "AGL Flutter Homescreen"
+DESCRIPTION = "Demo Flutter homescreen for Automotive Grade Linux."
+HOMEPAGE = "https://gerrit.automotivelinux.org/gerrit/apps/flutter-homescreen"
+SECTION = "graphics"
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/flutter-homescreen;protocol=https;branch=${AGL_BRANCH} \
+           file://flutter-homescreen-debug.json \
+           file://flutter-homescreen-profile.json \
+           file://flutter-homescreen-release.json \
+           file://flutter-homescreen.service \
+"
+SRCREV = "e21709c9601209e26d09dea0a45e37f0636bb605"
+
+S = "${WORKDIR}/git"
+
+PUBSPEC_APPNAME = "flutter_homescreen"
+FLUTTER_APPLICATION_INSTALL_PREFIX = "/flutter"
+
+FLUTTER_BUILD_ARGS = "bundle -v"
+
+inherit flutter-app
+
+APP_CONFIG = "flutter-homescreen-release.json"
+APP_CONFIG:class-runtimedebug = "flutter-homescreen-debug.json"
+APP_CONFIG:class-runtimeprofile = "flutter-homescreen-profile.json"
+
+do_install:append() {
+    install -D -m 0644 ${WORKDIR}/flutter-homescreen.service ${D}${systemd_user_unitdir}/flutter-homescreen.service
+    install -d ${D}${systemd_user_unitdir}/agl-session.target.wants
+    ln -s ../flutter-homescreen.service ${D}${systemd_user_unitdir}/agl-session.target.wants/flutter-homescreen.service
+
+    install -D -m 0644 ${WORKDIR}/${APP_CONFIG} ${D}${datadir}/flutter/flutter-homescreen.json
+}
+
+FILES:${PN} += "${datadir} ${systemd_user_unitdir}"