Add package group and bitbake target for Quality Assurance 89/5389/2
authorTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 10 Feb 2016 10:43:55 +0000 (19:43 +0900)
committerTadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
Wed, 10 Feb 2016 13:02:11 +0000 (13:02 +0000)
New packagegroup and bitbake target are added which
includes utilities for testing distribution.
It is assumed to be used in the Quality Assurance of AGL Distro.

New package group: packagegroup-agl-demo-platform-qa
New target: agl-demo-platform-qa

Change-Id: I96efde8348037821a6dfcd653e9fcbc87408f183
Signed-off-by: Tadao Tanikawa <tanikawa.tadao@jp.panasonic.com>
conf/conf-notes.txt
recipes-platform/images/agl-demo-platform-qa.bb [new file with mode: 0644]
recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb [new file with mode: 0644]
templates/intel-corei7-64/conf/conf-notes.txt
templates/qemux86-64/conf/conf-notes.txt
templates/qemux86/conf/conf-notes.txt

index 502690d..bdee76b 100644 (file)
@@ -1,5 +1,7 @@
 Common targets are:
     agl-image-ivi
     agl-image-ivi-crosssdk
+    agl-image-ivi-qa
     agl-demo-platform
     agl-demo-platform-crosssdk
+    agl-demo-platform-qa
diff --git a/recipes-platform/images/agl-demo-platform-qa.bb b/recipes-platform/images/agl-demo-platform-qa.bb
new file mode 100644 (file)
index 0000000..bec5e87
--- /dev/null
@@ -0,0 +1,11 @@
+SUMMARY = "A full set of AGL Distribution for testing as Quality Assurance"
+
+DESCRIPTION = "A full set of AGL Distribution. This image also has additional \
+packages (e.g. commandline tools) for Quality Assurance(QA)."
+
+require agl-demo-platform.bb
+
+IMAGE_INSTALL_append = " \
+    packagegroup-ivi-common-test \
+    packagegroup-agl-demo-platform-qa \
+    "
diff --git a/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb b/recipes-platform/packagegroups/packagegroup-agl-demo-platform-qa.bb
new file mode 100644 (file)
index 0000000..739f859
--- /dev/null
@@ -0,0 +1,15 @@
+SUMMARY = "The software for DEMO platform of AGL IVI profile"
+DESCRIPTION = "A set of packages belong to AGL Demo Platform includes utilities for testing distribution as Quality Assurance"
+
+LICENSE = "MIT"
+
+inherit packagegroup
+
+PACKAGES = "\
+    packagegroup-agl-demo-platform-qa \
+    "
+
+ALLOW_EMPTY_${PN} = "1"
+
+RDEPENDS_${PN} += "\
+    "
index 502690d..bdee76b 100644 (file)
@@ -1,5 +1,7 @@
 Common targets are:
     agl-image-ivi
     agl-image-ivi-crosssdk
+    agl-image-ivi-qa
     agl-demo-platform
     agl-demo-platform-crosssdk
+    agl-demo-platform-qa
index 502690d..bdee76b 100644 (file)
@@ -1,5 +1,7 @@
 Common targets are:
     agl-image-ivi
     agl-image-ivi-crosssdk
+    agl-image-ivi-qa
     agl-demo-platform
     agl-demo-platform-crosssdk
+    agl-demo-platform-qa
index 502690d..bdee76b 100644 (file)
@@ -1,5 +1,7 @@
 Common targets are:
     agl-image-ivi
     agl-image-ivi-crosssdk
+    agl-image-ivi-qa
     agl-demo-platform
     agl-demo-platform-crosssdk
+    agl-demo-platform-qa