ondemandnavi: Update recipe SRC_URI and HOMEPAGE 00/22000/3 8.0.0 halibut/8.0.0 halibut_8.0.0
authorScott Murray <scott.murray@konsulko.com>
Thu, 25 Jul 2019 12:31:54 +0000 (08:31 -0400)
committerScott Murray <scott.murray@konsulko.com>
Wed, 31 Jul 2019 16:55:53 +0000 (12:55 -0400)
Update recipe SRC_URI and HOMEPAGE to point at the new repository on
AGL Gerrit, and remove the local patches that have now been merged
there.  As well, the recipe has been reformatted to more closely match
the OpenEmbedded style guide and match those of the other demo
applications.

Bug-AGL: SPEC-2667

Change-Id: Ie771a2ea8e6236a5995dbb9c2b9d64cfbe30e89c
Signed-off-by: Scott Murray <scott.murray@konsulko.com>
recipes-demo-hmi/navigation/ondemandnavi/0001-switch-to-alsa-output.patch [deleted file]
recipes-demo-hmi/navigation/ondemandnavi/0002-update-permissions.patch [deleted file]
recipes-demo-hmi/navigation/ondemandnavi_git.bb

diff --git a/recipes-demo-hmi/navigation/ondemandnavi/0001-switch-to-alsa-output.patch b/recipes-demo-hmi/navigation/ondemandnavi/0001-switch-to-alsa-output.patch
deleted file mode 100644 (file)
index a93e8f9..0000000
+++ /dev/null
@@ -1,34 +0,0 @@
-ondemandnavi: Switch to ALSA output
-
-Update the talk scripts to use ALSA output via gst-launch-1.0 instead
-of 4A's 4a-play.  gstreamer is used since it is likely that a further
-revision will change to a pipewire output sink and add back setting a
-role property.
-
-Upstream-Status: pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/package/flite b/package/flite
-index 4c17b80..c837149 100755
---- a/package/flite
-+++ b/package/flite
-@@ -1,5 +1,4 @@
- #!/bin/sh
- TMP=/tmp/navi.wav
- echo "$1" | flite_hts_engine -m  /usr/share/Voice/us/cmu_us_arctic_slt.htsvoice -o $TMP
--4a-play $TMP hw:0,0,3 navigation
--
-+gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! alsasink
-diff --git a/package/jtalk b/package/jtalk
-index ed82281..c075317 100755
---- a/package/jtalk
-+++ b/package/jtalk
-@@ -1,6 +1,4 @@
- #!/bin/sh
- TMP=/tmp/navi.wav
- echo "$1" | open_jtalk -ow $TMP -m /usr/share/Voice/mei/mei_normal.htsvoice -x /usr/share/dic/
--4a-play $TMP hw:0,0,3 navigation
--
--
-+gst-launch-1.0 filesrc location=$TMP ! decodebin ! audioconvert ! audioresample ! alsasink
diff --git a/recipes-demo-hmi/navigation/ondemandnavi/0002-update-permissions.patch b/recipes-demo-hmi/navigation/ondemandnavi/0002-update-permissions.patch
deleted file mode 100644 (file)
index cff5fa9..0000000
+++ /dev/null
@@ -1,22 +0,0 @@
-ondemandnavi: Update permissions
-
-Add the new display and audio permissions required with the change to
-running as non-root.
-
-Upstream-Status: pending
-
-Signed-off-by: Scott Murray <scott.murray@konsulko.com>
-
-diff --git a/package/config.xml b/package/config.xml
-index ae5c1f6..10b2d99 100755
---- a/package/config.xml
-+++ b/package/config.xml
-@@ -13,6 +13,8 @@
-   <feature name="urn:AGL:widget:required-permission">
-     <param name="urn:AGL:permission::public:no-htdocs" value="required"/>
-     <param name="http://tizen.org/privilege/internal/dbus" value="required"/>
-+    <param name="urn:AGL:permission::public:display" value="required" />
-+    <param name="urn:AGL:permission::public:audio" value="required" />
-   </feature>
- </widget>
index 6cc2681..86ba532 100644 (file)
@@ -1,41 +1,41 @@
 SUMMARY     = "AGL Reference On Demand Navigation application."
-DESCRIPTION = "This application provides the function of Navigation to AGL. "
-HOMEPAGE    = "https://github.com/YoshitoMomiyama/aglqtnavigation.git"
+DESCRIPTION = "Demo AGL navigation application based on QtLocation widget."
+HOMEPAGE    = "https://gerrit.automotivelinux.org/gerrit/#/admin/projects/apps/ondemandnavi"
 SECTION     = "apps"
 
-LICENSE     = "Apache-2.0"
+LICENSE = "Apache-2.0"
 LIC_FILES_CHKSUM = "file://LICENSE;md5=ae6497158920d9524cf208c09cc4c984"
 
-inherit qmake5 aglwgt pkgconfig
+DEPENDS += "qtbase \
+            qtquickcontrols2 \
+            qlibhomescreen \
+            qlibwindowmanager \
+            qtlocation \
+            qtaglextras \
+"
 
-SRC_URI = "git://github.com/YoshitoMomiyama/aglqtnavigation.git;branch=master \
-           file://0001-switch-to-alsa-output.patch \
-           file://0002-update-permissions.patch \
-           file://org.agl.naviapi.conf \
-           "
-SRCREV  = "a6930c2dff988e45e18f91a2368d829c08942b30"
-
-DEPENDS += " qtbase qtquickcontrols2 \
-             qlibhomescreen \
-             qlibwindowmanager \
-             qtlocation qtaglextras \
-           "
-
-RDEPENDS_${PN} += " qtlocation \
-                    flite \
-                    openjtalk \
-                    gstreamer1.0 \
-                    ondemandnavi-config \
-                  "
+PV = "1.0+git${SRCPV}"
 
-RPROVIDES_${PN} = "virtual/navigation"
+SRC_URI = "git://gerrit.automotivelinux.org/gerrit/apps/ondemandnavi;protocol=https;branch=${AGL_BRANCH} \
+           file://org.agl.naviapi.conf \
+"
+SRCREV = "${AGL_APP_REVISION}"
 
 S = "${WORKDIR}/git"
 
+inherit qmake5 aglwgt pkgconfig
+
 do_install_append() {
    install -d ${D}/etc/dbus-1/session.d/
    install -m 0644 ${WORKDIR}/org.agl.naviapi.conf ${D}/etc/dbus-1/session.d/
 }
 
-PATH_prepend = "${STAGING_DIR_NATIVE}${OE_QMAKE_PATH_QT_BINS}:"
+RDEPENDS_${PN} += "qtlocation \
+                   flite \
+                   openjtalk \
+                   gstreamer1.0 \
+                   ondemandnavi-config \
+"
+
+RPROVIDES_${PN} = "virtual/navigation"